View Issue Details

IDCategoryLast Update
0008572bugs2021-02-11 15:45
ReporterfunkypouAssigned To 
Reproducibilityalways 
Status closedResolutionno change required 
PlatformUbuntuOSLinuxOS Version(any)
Product Version6.5 
Fixed in Version 
Summary0008572: Failed to instantiate LV2 plugin GxTuner
DescriptionWhen I try to insert GxTuner on a track from the plugin manager, a popup appears that says :
"The plugin "GxTuner" could not be loaded".

If I try to insert it from the favorites plugin, nothing happens.
Steps To ReproduceRight-click on a processor box to open the plugin manager. Double click on GxTuner and click on "Insert Plugin(s)" button.
A popup appears that says :
"The plugin "GxTuner" could not be loaded"
Additional InformationThe log shows this line :
[ERROR]: LV2: Failed to instantiate plugin http://guitarix.sourceforge.net/plugins/gxtuner#tuner

This is what appears on the terminal when I try to add the plugin :
lilv_lib_open(): error: Failed to open library /usr/lib/lv2/gxtuner.lv2/gxtuner.so (/usr/lib/lv2/gxtuner.lv2/gxtuner.so: undefined symbol: _ZN4Glib10Dispatcher7connectEON4sigc4slotIvNS1_3nilES3_S3_S3_S3_S3_S3_EE)

The plugin could be loaded on Adour 6.5 from the UbuntuStudio backport repo. The issue only appeared after I installed Ardour from the official binary. GxTuner also works on Carla.
TagsNo tags attached.

Activities

x42

2021-02-10 21:36

administrator   ~0025508

Nothing we can do here. The plugin needs to be statically linked and not rely on system-wide libraries (otherwise they can conflict with other plugin or host libraries).

Recent versions of guitarix are moving in that direction.

PS. You can work around by compiling ardour and the plugin with the same system-wide libs, but that's only a temporary workaround, until the next update.

funkypou

2021-02-11 02:01

reporter   ~0025510

Hi x42,

Thanks for your answer. I lack a bit of knowledge to fully understand your post so I had to do some research but I couldn't find all the answers.

Do you mean that Ardour's official binary uses static libraries (I couldn't find this in the Ardour website) and that GxTuner uses dynamic libraries ?
I presume that the Ardour binary from UbuntuStudio also uses dynamic libraries which would explain why GxTuner works in this version.

I don't use the most recent version of guitarix but the one from Ubuntu 20.04. Do you mean that I'm likely to experience this kind of issues later with other guitarix plugins, like amp simulators ? Do you discourage using this suite in Ardour ? These question are important because Ardour is the most advanced Linux open source DAW and guitarix is a must have open source LV2 guitar plugin suite so it looks like a major problem for the Linux FOSS users community if Ardour and guitarix don't match.

Thanks for the workaround suggestion but I won't compile Ardour (I'm a musician, you know) so I think I'll use GxTuner standalone app connected to Jack. In the worst case, I still can use Ardour from the UbuntuStudio repo.

x42

2021-02-11 10:00

administrator   ~0025512

> I don't use the most recent version of guitarix but the one from Ubuntu 20.04. Do you mean that I'm likely to experience this kind of issues later with other guitarix plugins,

Recent guitarix should not have this issue. Looks like Ubuntu still ships an older, incompatible one.

funkypou

2021-02-11 15:43

reporter   ~0025514

Thank you very much. I just misunderstood this sentence :
"Recent versions of guitarix are moving in that direction."
I thought you meant the direction of system-wide libraries. I'm reassured now and I think I can close the bug. Thanks again.

Issue History

Date Modified Username Field Change
2021-02-10 21:04 funkypou New Issue
2021-02-10 21:36 x42 Note Added: 0025508
2021-02-11 02:01 funkypou Note Added: 0025510
2021-02-11 09:30 walterdees File Added: idm crack kali crack.jpg
2021-02-11 09:55 x42 File Deleted: idm crack kali crack.jpg
2021-02-11 10:00 x42 Note Added: 0025512
2021-02-11 15:43 funkypou Note Added: 0025514
2021-02-11 15:45 funkypou Status new => closed
2021-02-11 15:45 funkypou Resolution open => no change required