View Issue Details

IDCategoryLast Update
0008552bugs2021-07-10 03:10
ReporterinFlowiaLabAssigned Tox42 
Reproducibilitysometimes 
Status closedResolutionsuspended 
PlatformLinuxOSUbuntu StudioOS Version19.10 x64
Product Version6.5 
Fixed in Version 
Summary0008552: Ardour lost files from session again
DescriptionArdour lost my files again. When opening the project, I received a message stating that the following files are missing:
MIDI-62.mid
MIDI-63.mid
MIDI-64.mid
Sparkles-5.mid
main-102.mid
main-12.mid
Before that, I opened 2 snapshots and 1 time opened the old version of the project in Ardor 5.12, which was created automatically when the project was converted to the format of the sixth version. Maybe this was the reason for the loss of files, I don't know.

At first, I could not find exactly where the lost files were in the project, as they were missing from the edit list on the Sources tab. This seemed very strange to me.
I managed to find them only after listening - they were empty regions without notes.

After saving the project and reopening it, the message about missing files was no longer displayed, although they were still missing. This seems to me to be very bad behavior, because if I hadn't written down the names, I would no longer have a chance to find out which files were lost.
I also found it a bit confusing that there was no suggestion to find them in this message about missing files. Just a list of files.

Then everything turned out to be even stranger. When I opened an old snapshot of the project from yesterday, I found that there is no problem with these files. All regions are working. When I looked at which files referenced regions that were problematic in the current version of the project, I realized that these are completely different files. Rather, these are files with different names.
As a result, all files were found. Here in the project directory, I just copied them and renamed them to the names that were lost - but that did not help ... If you open the project, all problem regions are still empty, although they point to files with these names.

Additional InformationThis is completely abnormal and I now understand that this happened with my projects before, just because the message about missing files is not displayed again, I thought that everything was decided by itself, although in fact files were dropped from the current version of the project and you can't even notice it. Regions with missing sources are no different from ordinary ones except that they are empty. But in order to notice that they are empty, you need to very carefully study the project, in which there may be more than a dozen regions and I really can't even know which path to look for it on. The name of the missing source often says absolutely nothing about the track to which it belongs, because after renaming the track, the source is not renamed in accordance with it. And Ardor has absolutely no help whatsoever in finding the region using the lost source. Firstly, lost sources and regions are not displayed in the edit list, and secondly, some sources and regions are not displayed there at all, even if they are not lost.
Tagslost sources, Midi, sources

Activities

unfa

2021-02-26 11:51

reporter   ~0025559

I've just had something like this happen in Ardour 6.6.
A few of my MIDI clips have suddenly become empty. My data is lost, I don't know what was there, I need to recreate it from scratch.

It's really frightening that Ardour does this.

unfa

2021-02-26 12:01

reporter   ~0025561

This kind of data loss happens regularly in my projects, and without warning. The MIDI files just become empty.

inFlowiaLab

2021-03-14 21:37

reporter   ~0025600

This happened again in another project. I created a snapshot of the project (I will call it snapshot 1) and worked in it (did Stem Export, duplicated midi tracks, combined all regions into one, deleted notes). Then I opened the main project again, made another snapshot (I'll call it snapshot 2). In this snapshot, I merged all midi regions into one region (for one track) and exported this midi region to a midi file in the export directory. Then I opened snapshot 1 again and got a message about a missing file:

"This session misses following midi files.
They have been replaced with silence:
Twang21.mid

The Regions and edits have been retained.
If this unexpected, manually locate the files and restore them in the session folder. Editing the MIDI files by adding new content will re-create the file and disable this warning, but also prevent future recovery of the original in the existing region(s)."

It should be noted here that I did not work with the track used by the Twang21.mid file in any way.
I would also like to draw your attention to the fact that, like last time, the disappearance of files occurs after creating snapshots and working with them.

inFlowiaLab

2021-03-14 21:49

reporter   ~0025601

Another extremely interesting observation: after I opened the main project, and then snapshot 2, the Twang21.mid file I created disappears again! I did some more experiments:
I created the Twang21.mid file, opened snapshot 1, closed Ardour and the file did not disappear.
Then I opened snapshot 2, the file still did not disappear. Then I closed Ardour and after that the file disappeared.
The same thing happened if I opened the main project instead of a snapshot 2.

inFlowiaLab

2021-03-26 19:52

reporter   ~0025643

And it happened again. 3 files from another project were lost.
Yesterday at the end of the day, I made one new snapshot and then a complete copy of the project (just copied the directory with the project). Today, when trying to open the project, there were 5 crashes. After upgrading to 6.6, projects often crash when opened. If this happens 2 times in a row, then I use one trick that helps me open the project: I do not open the main project, but the snapshot and snapshot, unlike the main project, opens successfully. After that I close the DAW and reopen the main project - after that it opens well.
This time I did the same. Having survived 5 crashes, I opened the snapshot, closed the DAW and reopened the main project - it opened, but 3 files were lost. I found them in a complete copy of the project directory (which I made yesterday).
From this we can conclude that snapshots are definitely involved in the loss of the file. Using snapshots is not safe.
There is still an unverified version that NTFS is to blame for everything. My projects are stored on an NTFS volume. Can anyone tell if this could be the cause of the problem?

x42

2021-07-08 19:13

administrator   ~0026042

This should be fixed since Ardour 6.7 (really since 6.6-146-g4bb3a896b4) -- please test and keep an eye out if this still happens

inFlowiaLab

2021-07-09 04:50

reporter   ~0026044

Since Ardour 6.6 I completely switched to another DAW. I cannot test this bug.

x42

2021-07-10 03:10

administrator   ~0026046

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2021-01-24 14:16 inFlowiaLab New Issue
2021-01-24 14:16 inFlowiaLab Tag Attached: lost sources
2021-01-24 14:16 inFlowiaLab Tag Attached: Midi
2021-01-24 14:16 inFlowiaLab Tag Attached: sources
2021-02-26 11:51 unfa File Added: Screenshot_20210226_124723.png
2021-02-26 11:51 unfa Note Added: 0025559
2021-02-26 12:01 unfa Note Added: 0025561
2021-03-14 21:37 inFlowiaLab Note Added: 0025600
2021-03-14 21:49 inFlowiaLab Note Added: 0025601
2021-03-26 19:52 inFlowiaLab Note Added: 0025643
2021-07-08 19:13 x42 Assigned To => x42
2021-07-08 19:13 x42 Status new => feedback
2021-07-08 19:13 x42 Note Added: 0026042
2021-07-09 04:50 inFlowiaLab Note Added: 0026044
2021-07-09 04:50 inFlowiaLab Status feedback => assigned
2021-07-10 03:10 x42 Status assigned => resolved
2021-07-10 03:10 x42 Resolution open => suspended
2021-07-10 03:10 x42 Note Added: 0026046
2021-07-10 03:10 x42 Status resolved => closed