View Issue Details

IDCategoryLast Update
0008500bugs2021-01-05 16:14
ReporterstillbreathingAssigned Topaul 
Status resolvedResolutionno change required 
PlatformMicrosoftOSWindowsOS Version10
Product Version6.5 
Fixed in Version 
Summary0008500: Ardour does not honor display scaling
DescriptionArdour 6.5 does not honour the scaling settings in Windows, making the UI extremely small and very difficult to use. I have recently upgraded from Ardour 6.1 (I think) which worked correctly.

I have a Dell XPS 15" laptop with a 4K display (3840x2160), connected to a Dell 34" monitor (3440x1440). Window scaling is set at the recommended 250%.

The attachments show what this looks like to me, and the problem affects the tracks window, the mixer window and all dialogue boxes. The title bar of the windows and dialogue boxes is the correct size, but everything inside the windows is tiny.

I've installed a new version of the Dell Display Manager app (which handles some settings on the 34" monitor) and rebooted several times. I've also tried changing several preferences in the "Appearence" section.
Steps To ReproduceWindows 10, version 1909 (build 18363.1256).

Dell XPS 15" laptop with 4K display with scaling set to 250%.

Dell 34" monitor.
Tagsdisplay, double screen, scaling, ui, Windows



2020-12-15 08:05


scaling-issue-1.png (29,546 bytes)
scaling-issue-1.png (29,546 bytes)
scaling-issue-2.png (7,706 bytes)
scaling-issue-2.png (7,706 bytes)


2020-12-15 13:51

administrator   ~0025314

When you say "Window scaling", do you mean Ardour's Preferences > Appearance > GUI and Font scaling?


2020-12-15 14:59

reporter   ~0025315

No, I meant the scaling setting as set in Windows itself - it compensates for high-dpi screens be allowing the user to scale up apps. Previous versions of Ardour seemed to support this scaling automatically, but 6.5 doesn't.

I didn't know about the Preferences > Appearance > GUI and Font scaling option (as I've never had to use it!), so thank you for telling me about that. Setting that to the maximum means that Ardour is now usable for me.

I have to admit I've noticed some strange scaling issues in one other app (OpenShot) so it may be that a recent Windows update has caused the error. I'm investigating further. Thanks.


2020-12-15 15:38

administrator   ~0025316

Last edited: 2020-12-15 15:39

View 2 revisions

> I meant the scaling setting as set in Windows itself

The scaling used for common desktop/spreadsheet applications is usually not applicable for authoring tools. At first application start, Ardour offers to configure scaling (relative to desktop default font-size).
And you can later customize it in Preferences > Appearance.


2020-12-15 17:28


dpi-properties.png (16,909 bytes)
dpi-properties.png (16,909 bytes)


2020-12-15 17:28

reporter   ~0025317

The scaling I'm talking about has previously worked for Ardour, and works for many other non-common desktop applications (I'm a software developer by trade, so have all manner of stuff installed).

However, I have fixed it, using the settings discussed here:

Hopefully this will help any other Windows users who have the same issue.

Issue History

Date Modified Username Field Change
2020-12-15 08:05 stillbreathing New Issue
2020-12-15 08:05 stillbreathing Tag Attached: display
2020-12-15 08:05 stillbreathing Tag Attached: double screen
2020-12-15 08:05 stillbreathing Tag Attached: scaling
2020-12-15 08:05 stillbreathing Tag Attached: ui
2020-12-15 08:05 stillbreathing Tag Attached: Windows
2020-12-15 08:05 stillbreathing File Added: scaling-issue-1.png
2020-12-15 08:05 stillbreathing File Added: scaling-issue-2.png
2020-12-15 13:51 x42 Note Added: 0025314
2020-12-15 14:59 stillbreathing Note Added: 0025315
2020-12-15 15:38 x42 Note Added: 0025316
2020-12-15 15:39 x42 Note Edited: 0025316 View Revisions
2020-12-15 17:28 stillbreathing File Added: dpi-properties.png
2020-12-15 17:28 stillbreathing Note Added: 0025317
2021-01-05 16:14 paul Assigned To => paul
2021-01-05 16:14 paul Status new => resolved
2021-01-05 16:14 paul Resolution open => no change required