View Issue Details

IDCategoryLast Update
0008496bugs2020-12-13 15:28
ReporterBrnVrnAssigned Tox42 
Reproducibilityalways 
Status resolvedResolutionfixed 
PlatformGNUOSLinuxOS Version(any)
Product Version6.5 
Fixed in Version 
Summary0008496: Configured VST3 path is not used
DescriptionIn the preference, the "Additional VST3 path" is actually the `plugin-path-vst` and not the `plugin-path-vst3` in the config file.
And indeed, plugins installed in path configured via the preferences are not discovered.

If I install the VST3 plugin in `~/.vst3/` it works. But since I install them via my Linux distribution's package manager, that is not an option.
Steps To Reproduce1/ Install VST3 plugins in, for example: `/usr/lib64/vst3/`
2/ In ardour preferences add the `/usr/lib64/vst3/` Path to the "Additional VST3 path".
3/ Rescan, restart, reboot ...
4/ In the "Plugin Manager" search for VST3 plugin ... there are none
Additional InformationIf I manually edit the config file and add the path to the `plugin-path-vst3` option,
Then Ardour discover my plugins and I can use them.
It does not show up anywhere in the preferences.
TagsPreferences, VST

Activities

x42

2020-12-13 15:28

administrator   ~0025304

Already fixed in 6.5.29

Issue History

Date Modified Username Field Change
2020-12-13 15:06 BrnVrn New Issue
2020-12-13 15:06 BrnVrn Tag Attached: Preferences
2020-12-13 15:06 BrnVrn Tag Attached: VST
2020-12-13 15:28 x42 Assigned To => x42
2020-12-13 15:28 x42 Status new => resolved
2020-12-13 15:28 x42 Resolution open => fixed
2020-12-13 15:28 x42 Note Added: 0025304