View Issue Details

IDCategoryLast Update
0008464features2020-12-02 18:36
ReporterOliverAssigned To 
Reproducibilityalways 
Status closedResolutionopen 
PlatformUbuntuOSLinuxOS Version(any)
Product Version6.3 
Fixed in Version 
Summary0008464: Ardour does not fit full screen if path name too long
DescriptionI carefully adjusted the GUI so it fits in full-screen mode ('Maximize editor space') on my 1024x768 display. If I open a session in a deep directory (long path name), it does not fit anymore, apparently because the path name in the header line makes the window expand.

If I reduce the path length by moving the session to a higher directory, or if I disable the path indication in the header, it fits again.

It would be useful to shorten the path indication in this case, maybe similar to the 'Track name ellipsis mode'.
TagsNo tags attached.

Activities

Oliver

2020-12-02 18:36

reporter   ~0025276

The new 'Name' entry in Ardour 6.5 for the header line is sufficient for me and is much shorter than the full path, so should not result in undue window expansion.

Implementing 'ellipis' for the path name might still be useful for other with a deep directory structure.

Issue History

Date Modified Username Field Change
2020-11-01 09:25 Oliver New Issue
2020-12-02 18:36 Oliver Status new => closed
2020-12-02 18:36 Oliver Note Added: 0025276