View Issue Details

IDCategoryLast Update
0008451bugs2020-11-24 05:22
ReporternbadgerAssigned To 
Reproducibilityrandom 
Status newResolutionreopened 
PlatformMicrosoftOSWindowsOS Version7
Product Version6.3 
Fixed in Version 
Summary0008451: Crashes randomly when stopping playback
DescriptionOften crashes with a box "the application has requested the runtime to terminate it in an unusual way" or glibmm-error. Happens more often with bigger projects. On current project with 30 tracks it typically crashes after 10-20 play/stop operations, making it effectively unusable.
TagsNo tags attached.

Activities

x42

2020-10-27 23:17

administrator   ~0025173

This is not a common issue and I cannot reproduce it (Win7Pro, 64bit). Does it happen with every session, or only with a specific one?
  
Could you try running a recent build from https://nightly.ardour.org ?
That will automatically write a crash-log: %localappdata%\Ardour6\CrashLog\

nbadger

2020-10-28 08:12

reporter   ~0025175

Happens with most sessions, except some small ones (only a few tracks). Happens more frequently the bigger the project is, and maybe more often if there's more midi tracks. Latest project has about 25 audio tracks and 10 midi, and it crashes after maybe 10-20 starts/stops. Will run the nightly build and report back. Also I didn't mention it but I'm using 32-bit Ardour.

nbadger

2020-10-28 08:21

reporter   ~0025176

OK it crashed on loading my session (same error). But %localappdata%\Ardour6\CrashLog\ has no files.

Oliver

2020-11-06 12:29

reporter   ~0025204

I see similar behaviour with Ardour 6.3 on Linux, 64-bit, happening after about 10 start/stops. This definitely did not happen in 5.12, and I also do not recall it with 6.1.

There is a very brief audio noise (possibly stuttering for a fraction of a second), then the Ardour window closes and I see an x-run in Qjackctl.

It also happens with Ardour-6.3.282-dbg-x86_64-gcc5. Where can I find the mentioned automatic crash-log on Linux?

Oliver

2020-11-06 16:12

reporter   ~0025206

For my case, I determined now conclusively that the crash is due to one (particular) instance of the 'Dragonfly Room Reverb' plug-in.

I have two instances in the session, one on a track, the other on the Master Bus:
- with both enabled, Ardour crashes each time after between 1 to 15 start/stop cycles (crash is always at the 'stop' moment)
- if I disable the plug-in instance on the track, there are no more crashes with 30-plus such cycles
- if I disable only the instance on the Master Bus, it crashes as before.

Of importance might be that the track at the moment is empty, so the track plug-in is fed silence, versus some signal is arriving at the Master Bus.

Oliver

2020-11-06 17:23

reporter   ~0025207

The crash can be reproduced with only a single Dragonfly Room reverb on the Master Bus and no other plug-ins.

Additionally, I found that it crashes only if the Ardour option ‘Silence plugins when the transport is stopped’ is enabled (see also https://discourse.ardour.org/t/dragonfly-room-verb-attacked-me-last-night/104432/44?u=oliver_grimm)

nbadger

2020-11-07 23:47

reporter   ~0025208

I stripped my "bad" session down to a smaller number of tracks and plugins until it crashed only infrequently, then started adding back in the stuff I had before. First crash was when I added Freeverb ProG to my drum track (which is samples in sforzando). Removed and replaced with Convology. That crashed too. Removed it. Added a drum aux send and put ReaComp on it. That crashed. Dunno, I just can't pin it down to any particular plugin, but with more tracks and/or more effects the crashes happen more frequently. BTW I have "Silence plugins when Transport stopped" unchecked.

I love Ardour but it's too unreliable to be useful on large projects.

Oliver

2020-11-14 19:49

reporter   ~0025221

The crash I reported does not occur anymore with Ardour 6.3.317 (rev 6.3-317-gf7cb1b0b48), as hinted at in the forum (https://discourse.ardour.org/t/dragonfly-room-verb-attacked-me-last-night/104432/48?u=oliver_grimm).

nbadger

2020-11-14 23:14

reporter   ~0025227

Great, I'll try it. I tried to download the full version but it says I need a subscription, which I don't have. However, I did pay for Ardour 6.1, and I thought that entitled me to upgrades. Is there a way to get the full version? Thx.

nbadger

2020-11-22 02:31

reporter   ~0025253

6.3.317 does NOT fix the problem. It crashed on Stop three times in the past hour. Same message "the application has requested the runtime to terminate it in an unusual way"

nbadger

2020-11-24 05:22

reporter   ~0025259

Sadly, 6.5 crashes pretty frequently too.

Issue History

Date Modified Username Field Change
2020-10-23 03:17 nbadger New Issue
2020-10-27 23:17 x42 Note Added: 0025173
2020-10-28 08:12 nbadger Note Added: 0025175
2020-10-28 08:21 nbadger Note Added: 0025176
2020-11-06 12:29 Oliver Note Added: 0025204
2020-11-06 16:12 Oliver Note Added: 0025206
2020-11-06 17:23 Oliver Note Added: 0025207
2020-11-07 23:47 nbadger Note Added: 0025208
2020-11-14 19:49 Oliver Note Added: 0025221
2020-11-14 20:56 x42 Assigned To => x42
2020-11-14 20:56 x42 Status new => resolved
2020-11-14 20:56 x42 Resolution open => fixed
2020-11-14 23:14 nbadger Note Added: 0025227
2020-11-22 02:31 nbadger Note Added: 0025253
2020-11-22 04:06 x42 Assigned To x42 =>
2020-11-22 04:06 x42 Status resolved => new
2020-11-22 04:06 x42 Resolution fixed => reopened
2020-11-24 05:22 nbadger Note Added: 0025259