View Issue Details

IDCategoryLast Update
0008423features2021-01-23 20:06
ReporterhubAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformGNUOSLinuxOS Version(any)
Product Version6.3 
Fixed in Version 
Summary0008423: Ardour VST3 support should honour VST3_PATH
DescriptionTested with Ardour 6.3-95-g751db481a6

Ardour should also look for VST3 plugins in VST3_PATH.

Indeed, the VST3 specs says, for Linux
> On the Linux platform, the host application expects VST 3 plug-ins to be located in:
>
and then list some directories.

https://steinbergmedia.github.io/vst3_doc/vstinterfaces/vst3loc.html

But reading it, I don't see anything prohibiting for having extra path to look for, that would have the lowest priority, and that could be specified by VST3_PATH like it is done with LXVST_PATH and LV2_PATH. Even if it is only for the first run.

The use case I'm looking at is Flatpak, but this solution is nothing specific to it.
TagsNo tags attached.

Activities

hub

2020-09-27 00:11

reporter   ~0025060

Example of apps (that I tried) that supports VST3_PATH on Linux:

- Carla
- BitwigStudio

hub

2020-10-12 15:16

reporter   ~0025120

I stand corrected, BitwigStudio doesn't support it. But they support adding custom path (and I hadn't cleaned the settings when re-testing)

BTW filed an issue with the SDK
https://github.com/steinbergmedia/vst3sdk/issues/67

x42

2021-01-23 20:06

administrator   ~0025450

It is now possible to set a custom path since 6.5

anonymous

2021-01-23 20:06

viewer   ~0025451

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-09-26 23:52 hub New Issue
2020-09-27 00:11 hub Note Added: 0025060
2020-10-12 15:16 hub Note Added: 0025120
2021-01-23 20:06 x42 Assigned To => x42
2021-01-23 20:06 x42 Status new => resolved
2021-01-23 20:06 x42 Resolution open => fixed
2021-01-23 20:06 x42 Note Added: 0025450
2021-01-23 20:06 anonymous Note Added: 0025451
2021-01-23 20:06 anonymous Status resolved => closed