View Issue Details

IDCategoryLast Update
0008392bugs2020-11-03 00:23
ReporterwargreenAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
Platformx86_64OSDebianOS VersionSID
Product Version6.2 
Fixed in Version 
Summary0008392: Audio input muted when seek in the timeline
DescriptionWith tracks monitoring input, seeking in the timeline seem mute the output.
Steps To ReproduceAdd track with input monitor
Seek in the timeline
Additional InformationScreen of the audio output of the track attached
TagsNo tags attached.

Activities

wargreen

2020-09-04 00:23

reporter  

Cut_Ardout.png (90,187 bytes)
Cut_Ardout.png (90,187 bytes)

x42

2020-09-04 00:55

administrator   ~0025007

Quick analysis of the issue (fix pending):

This is due to libs/ardour/session_process.cc:469
if (!process_can_proceed()) {   _silent = true; return }


Inside Ardour there is no glitch (no routes are processed, time stands still), but it interrupts live input monitoring.

x42

2020-09-04 00:59

administrator   ~0025008

Easier way to reproduce:
 * create a mono track
 * add a signal generator to the track (e.g. Lua script)
-> generated signal is audible
 * move the transport around
hear glitches in the output

(A scope on the master-bus does not show this, but an external oscilloscope e.g. JACK-app does)

x42

2020-09-05 18:05

administrator   ~0025011

Fixed in Ardour 6.2-249-g1a3da7e132

Please test, in particular that this does not have any side-effects.

wargreen

2020-09-07 15:07

reporter   ~0025017

Can't launch my live session here, but it seem to be fixed in a test session with 6.3.0. This week i will work on another project so i'll see if any side-effect in mixing conditions.

wargreen

2020-09-30 22:00

reporter   ~0025089

It seem to be fixed, without any side-effect, i've used my full session several times and all work well.
Thank you !

x42

2020-09-30 22:45

administrator   ~0025091

Confirmed fixed since Ardour 6.2-249-g1a3da7e132

anonymous

2020-11-03 00:23

viewer   ~0025197

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-09-04 00:23 wargreen New Issue
2020-09-04 00:23 wargreen File Added: Cut_Ardout.png
2020-09-04 00:55 x42 Note Added: 0025007
2020-09-04 00:59 x42 Note Added: 0025008
2020-09-05 18:05 x42 Assigned To => x42
2020-09-05 18:05 x42 Status new => feedback
2020-09-05 18:05 x42 Note Added: 0025011
2020-09-07 15:07 wargreen Note Added: 0025017
2020-09-07 15:07 wargreen Status feedback => assigned
2020-09-30 22:00 wargreen Note Added: 0025089
2020-09-30 22:45 x42 Status assigned => resolved
2020-09-30 22:45 x42 Resolution open => fixed
2020-09-30 22:45 x42 Note Added: 0025091
2020-11-03 00:23 anonymous Note Added: 0025197
2020-11-03 00:23 anonymous Status resolved => closed