View Issue Details

IDCategoryLast Update
0008390other2020-10-24 07:35
ReporterunfaAssigned To 
Reproducibilityalways 
Status resolvedResolutionfixed 
Product Version6.2 
Fixed in Version 
Summary0008390: Ardour comes bundled with proprietary software and plug-in demo versions
DescriptionI've talked about this before, but I guess it got lost, so I'm bringing it up again.

1. Ardour for Linux comes bundled with proprietary Harrison GUIs for some of the stock Ardour plug-ins.

I think the GUIs are nice and all, but I run Ardour *specifically* because it's free software, and I just don't want to have it served with proprietary binary code that I have no idea what is doing.

I'd be most happy to see the Harrison GUIs be open-sourced as contribution to Ardour, but I don't expect that.

Since that's the case, I want to be able to have Ardour install without any proprietary plug-ins or plug-in GUIs.
And since Ardour's big selling point is the open-source nature of the project, I'd rather have these as opt-in than opt-out.
I guess the unofficial builds available in various Linux distributions will come without them, but I'd like to not be forced to use these to get a 100% free-software package.

2. Ardour for Windows comes bundled with demo versions of proprietary Harrison plug-ins.
I guess Windows users aren't complaining about it, but honestly this is nothing more than an annoying advertisement for Harrison software - these plug-in are near useless unless the user purchases a license. The Harrison plug-in GUIs are at least fully functional. I think it'd be best to get rid of this stuff, or at least provide an opt-out during installation. Or better: an opt-in.

3. There's also useless demo versions of paid x42 plug-ins bundled, which at least are free software, but still this is shovelware, becasue they are useless unless the user purchases a license.

I have nothing against paid FOSS plug-ins, and I think the x42 plug-ins are of great quality, but I'd highly prefer if Ardour bundled only fully functional plug-ins, not placeholders asking for a license.

---

One of the first things I do on any fresh Ardour installation on Windows is to mark all the useless demo plug-ins as hidden. This doesn't create a good user experience where 90% of the stock plug-ins turn out to be just cardboard cut-outs asking for more money (the user has already paid *something* to get the Windows build of Ardour).

I know this is done to help fund Ardour's development and support it's creators (x42 plug-ins etc.) and you probably have a deal with Harrison to bundle their demo versions, but it's not looking good for the users, especially those who are sensitive to software freedom.

Please provide users with a choice to *not* install proprietary GUIs or demo versions of plug-ins with Ardour.
Instead - please consider bundling fully functional plug-ins like x42 MIDI Filters, x42 DPL, x42 Tuna and x42 Autotune - these would greatly compliment Ardour's stock plug-in set and give users a better experience.
TagsNo tags attached.

Activities

x42

2020-08-31 21:10

administrator   ~0024994

> And since Ardour's big selling point is the open-source nature of the project

https://discourse.ardour.org/t/is-open-source-a-diversion-from-what-users-really-want/102665

> and you probably have a deal with Harrison to bundle their demo versions

Only an agreement that we can legally do so. We're glad that Harrison allows those to be bundled.
The main benefit here is that you can load sessions of other using the plugins -- the limitation is only the custom plugin GUI. The DSP is excellent, generally better than free software alternatives and you get it gratis. Even the generic UI works and they're even using a libre standard (LV2), I wish more plugin vendors would follow their lead.

No DRM. No hardware keys, no demo noise. -- I honesty think we should promote this and get more companies to ship cross-platform plugins in similar fashion if they cannot release the software under a free/libre license.

The only reason to not want them is a purism, and I found that best approach is to let those guys weed out files not matching their ideology themselves. Really, they should not trust us in the first place even if we add an opt in/out. :)

x42

2020-08-31 21:12

administrator   ~0024995

> I know this is done to help fund Ardour's development and support it's creators

Actually that's not the reason.
The plugins were added for user's convenience, because users asked if we we can include the plugins that are bundled with Mixbus also with Ardour.

unfa

2020-08-31 22:35

reporter   ~0024996

Thanks for clearing this up. I'm gonna read up on Paul's post later as it's quite a lengthy read.

It seems my assumption that the main drive for these plug-ins / GUIs to be included was upselling or product cross-promotion was wrong. And I am glad to be proven wrong there.

I know most users will not complain about it, or even notice - but for people like me who have decided on principle to run as little proprietary software as possible - this is a bummer.
Yes, we can dig files up, ask around and delete what we don't want after the installation, or just depend on unofficial builds where package maintainers have stripped this out for us.
Yet - it's not convenient and it's creating a suboptimal experience for a certain group of Ardour users if they choose to use official Ardour binaries.
I'd expect these should give the best possible experience to all users, shouldn't they?

It's not far away to say "if you don't like that just make your own build" - and it's not reasonable to expect regular users to be able to jump such hoops. And digging into program files to weed out proprietary plug-in binaries is far beyond the reach of an average non-savvy user. Should these people be forced to use proprietary software when they download Ardour (and open a-EQ), when it's advertised as a free/libre program? It's a bit misleading and I am surprised nobody has raised this issue before me.

I understand that it wasn't done viciously, but I think a clear information and a checkbox or two in the installer would go a long way here.

[ x ] Install additional open-source x42 plug-in demo versions
[ x ] Install additional proprietary Harrison plug-in demo versions

What do you think?

jumase

2020-09-09 19:44

reporter   ~0025022

I started using Ardour mainly as a political/ethical reason -political in an general/wide/'ancient' sense: politike techne, how we (want to) treat each other on a community. I was taught audio processing on an institution using proprietary software, but I wanted to prove (myself) I could be able to perform similar tasks with a more politically committed software.

And I see it's a difficult topic what Paul posted. I couldn't contribute as a developer as I don't know any program language. As far as I can get is reporting bugs, supporting as I can, spreading among my contacts, learning how to use the software and using it. I think that we all are influenced by conservative ideas (we are born in between them) so there are great chances that we get more "advices" to do it the way it is supposed to (as many users would ask too, mainly in DAW stuff). I know you know that, otherwise you wouldn't keep working on the projects and wouldn't have written all those post stating your point of view.

On the other hand, what you call "gratis" (in term of money), is not in other aspects. For example, the company is getting advertising as an exchange (the logo is there and I guess you could not remove it). Is it necessary to apply the proprietary GUI on Ardour's native plugins? I don't understand how is that allowing to load sessions that use Mixbus plugins; or I got it wrong?

We do put trust in many projects, not only Ardour. A community is based on trust, any relation is based on trust. And one obviously get some clues, judge, pre-judge, based on what others do... Think about food: there's a long chain that's imposible to be verified by 'external' people.

I agree that there would be fair not to include proprietary software by default, and a good approach could be what unfa proposes about extra demo plugins. And what about native plugins (a-EQ, a-Compressor, a-Delay)? Why do they have to use Mixbus GUI?

jumase

2020-09-09 23:52

reporter   ~0025023

>best approach is to let those guys weed out files

Sorry, never thought you were being literal :)

x42

2020-09-10 00:01

administrator   ~0025024

just delete the LV2/Harrison.lv2 folder

x42

2020-09-10 00:03

administrator   ~0025025

> And what about native plugins (a-EQ, a-Compressor, a-Delay)? Why do they have to use Mixbus GUI?

The LV2 plugin standard allows separate 3rd party GUIs for any plugin. In the last 3 years nobody stepped up and provided commercial-quality cross-platform UIs.
Ben at Harrison eventually volunteered to make some (a-eq is done, the others are functional but still being worked on).

If someone creates a better GUI, we'll happily ship that instead.

The goal of the Ardour bundles from ardour.org/download is to create a good out-of-the-box experience for typical users.

jumase

2020-09-10 17:51

reporter   ~0025026

I see the point, thanks for clarifying.

x42

2020-09-29 18:34

administrator   ~0025082

I forgot to follow up, but since Sep/10 the windows installer allows to opt-out of installing the Harrison plugins.
I hope this concludes this issue.

x42

2020-09-29 18:34

administrator   ~0025083

Addressed in 6.3-8-gf61ecae4b2

unfa

2020-09-29 23:32

reporter   ~0025084

Thanks! What about the Linux installers? Do they provide a choice too?

x42

2020-09-30 01:04

administrator   ~0025085

For GNU/Linux, 6.3 installers already offer to opt-out (that was changed in 6.2-201-g81fb723561; August/21).

macOS does not have an installer, so we cannot change this there.

unfa

2020-09-30 09:22

reporter   ~0025087

Thanks! I'll check this out and let known if I see any issues.

I guess for MacOS a solution could be to provide two packages - one with and one without the proprietary components?

unfa

2020-10-02 11:18

reporter   ~0025099

I've just got a development build and intalled it - it didn't ask about the proprietary plug-ins, and just installed them as usual:

$ pwd
/opt/Ardour-6.3.123/lib/LV2
[unfa@unfa-desktop LV2]$ ls
a-comp.lv2 a-delay.lv2 a-eq.lv2 a-exp.lv2 a-fluidsynth.lv2 a-reverb.lv2 gmsynth.lv2 Harrison.lv2 reasonablesynth.lv2

Here's the installer output:

$ ./Ardour-6.3.123-x86_64-gcc5.run
Verifying archive integrity... 100% All good.
Uncompressing Ardour 100%

Welcome to the Ardour installer

Ardour will be installed for user unfa in /opt

[sudo] password for unfa:
Fri Oct 2 01:13:54 PM CEST 2020
Architecture is x86_64
Checking for required disk space
Bundle is on tmpfs filesystem
Unpacking bundle for x86_64
Bundle unpacked

Checking system libs to see if they are compatible with Ardour.


Found existing Ardour installation.
Do you want to run the uninstaller /opt/Ardour-5.12.0.uninstall.sh ? [y/n]: n

Found existing Ardour installation.
Do you want to run the uninstaller /opt/Ardour-6.3.0.uninstall.sh ? [y/n]: n

Found existing Ardour installation.
Do you want to run the uninstaller /opt/Ardour-6.3.55.uninstall.sh ? [y/n]: n

Installing Ardour 6.3.123 in /opt

Adding Ardour to the applications menu

Creating a desktop link for Ardour in /home/unfa/Desktop

Copying uninstall script to /opt


Creating link Ardour6 in /usr/local/bin


Checking to see if Jack is installed

Jack already present

Jack Version Check OK (jackdmp version 1.9.14 tmpdir /dev/shm protocol 8)

which: no qjackctl in (/home/unfa/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/bin:/var/lib/flatpak/exports/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl)

The program QjackCtl is missing from this system.
QjackCtl is an extremely useful tool for any system that runs JACK applications like Ardour.
We recommend that you install it.

Install QjackCtl using system software repository? [y/n]: n

Cleaning up

!!! Install Complete !!!

Press ENTER to exit installer:

x42

2020-10-02 11:59

administrator   ~0025100

Oh dear, I've screwed up the path (missing `lib/`), thanks for catching that.

Fixed in https://github.com/Ardour/ardour/commit/e2639a1a588b8f75b101eb48bb717b78dabee7e3

unfa

2020-10-18 15:08

reporter   ~0025128

Allright, I've tested this and the proprietary plug-in opt-out works - thanks!

I haven't tested a Windows build and the x42 demo versions - what about these?

What do you think about bundling the free x42 plug-ins instead?
These would provide great value to users, and do not require any payment.
I think they'd greatly compliment Ardour's stock plug-in set.

x42

2020-10-18 15:13

administrator   ~0025129

While they're free-software the ready-to-run x42 binaries are commercial. Probably not what you'd expect either.

unfa

2020-10-18 19:39

reporter   ~0025131

Yes, but there's a bunch of "free" (no cost) ones as well listed here:
https://x42-plugins.com/x42/
Digital Peak Limiter, Autotune, setBfree and more - what about these?

x42

2020-10-18 20:39

administrator   ~0025132

I prefer not to tie release cycles of those plugins with Ardour releases.
5.12 -> 6.0 was 2 1/2 years without an ardour release, while at the same time there have been 16 x42-plugins releases.

And where would we stop? Bundle LSP, or DPF plugins?

Ardour's philosophy is to remain as neutral as reasonable and leave coloring DSP out (as opposed to Mixbus which focuses on a given sound character).
One thing I would be interested in is adding a few more a-*/ACE-* plugins that have tight integration in a matter that plugins otherwise cannot provide.
e.g. build-in noise-repellant, right-click on a region -> analyze and remove noise faster than realtime.

soundguy30

2020-10-24 07:35

reporter   ~0025147

Ardour should maybe have a build version that is just free open source version no other plugins from 3rd parties.

Issue History

Date Modified Username Field Change
2020-08-31 20:10 unfa New Issue
2020-08-31 21:10 x42 Note Added: 0024994
2020-08-31 21:12 x42 Note Added: 0024995
2020-08-31 22:35 unfa Note Added: 0024996
2020-09-09 19:44 jumase Note Added: 0025022
2020-09-09 23:52 jumase Note Added: 0025023
2020-09-10 00:01 x42 Note Added: 0025024
2020-09-10 00:03 x42 Note Added: 0025025
2020-09-10 17:51 jumase Note Added: 0025026
2020-09-29 18:34 x42 Note Added: 0025082
2020-09-29 18:34 x42 Status new => resolved
2020-09-29 18:34 x42 Resolution open => fixed
2020-09-29 18:34 x42 Note Added: 0025083
2020-09-29 23:32 unfa Note Added: 0025084
2020-09-30 01:04 x42 Note Added: 0025085
2020-09-30 09:22 unfa Note Added: 0025087
2020-10-02 11:18 unfa Note Added: 0025099
2020-10-02 11:59 x42 Note Added: 0025100
2020-10-18 15:08 unfa Note Added: 0025128
2020-10-18 15:13 x42 Note Added: 0025129
2020-10-18 19:39 unfa Note Added: 0025131
2020-10-18 20:39 x42 Note Added: 0025132
2020-10-24 07:35 soundguy30 Note Added: 0025147