View Issue Details

IDCategoryLast Update
0008388bugs2020-08-30 19:20
ReportermoonshaadowAssigned Tox42 
Reproducibilityalways 
Status resolvedResolutionfixed 
PlatformUbuntuOSLinuxOS Version(any)
Product Version6.2 
Fixed in Version 
Summary0008388: Wrong parameter automation when opening with 6.2 a project created in 5.12
DescriptionWhen loading a session created in 5.12, some automation points are wrong in a-delay plugin. Wrong parameter ('Feedback' instead of 'LPF'), wrong values.
Steps To Reproduce- Create a new session with ardour5
- Add new track --> add 'a-delay' plugin --> write an automation on , i.e., 'LPF' parameter
- Save the session, open it with ardour6 and compare automation.
Additional InformationWe can see in image that many parameters are affected. I haven't test with other plugins.
TagsNo tags attached.

Activities

moonshaadow

2020-08-30 16:49

reporter  

ardour5.png (58,934 bytes)
ardour5.png (58,934 bytes)
ardour6.png (68,646 bytes)
ardour6.png (68,646 bytes)

x42

2020-08-30 17:21

administrator   ~0024985

Fixed in a-delay that comes with Ardour 6.2-215-g7cdefbe8e7.

The problem, is that automation that you have written since 6.2 will now will be using the incorrect port.

x42

2020-08-30 17:21

administrator   ~0024986

I'm sorry for the inconvenience.

moonshaadow

2020-08-30 19:20

reporter   ~0024987

Not a big deal for my work, I was only scared about a potential bigger problem affecting many plugins.
Thank you.

Issue History

Date Modified Username Field Change
2020-08-30 16:49 moonshaadow New Issue
2020-08-30 16:49 moonshaadow File Added: ardour5.png
2020-08-30 16:49 moonshaadow File Added: ardour6.png
2020-08-30 17:21 x42 Note Added: 0024985
2020-08-30 17:21 x42 Assigned To => x42
2020-08-30 17:21 x42 Status new => resolved
2020-08-30 17:21 x42 Resolution open => fixed
2020-08-30 17:21 x42 Note Added: 0024986
2020-08-30 19:20 moonshaadow Note Added: 0024987