View Issue Details

IDCategoryLast Update
0008314bugs2020-07-16 19:56
ReporterfoxAssigned Tox42 
Reproducibilityalways 
Status resolvedResolutionfixed 
PlatformLinuxOSopenSUSE TumbleweedOS Versionrolling
Product Version6.2 
Fixed in Version 
Summary0008314: Can't build 6.x with errors in ../libs/pbd/pbd/mpmc_queue.h
DescriptionNo matter how I fiddled about with build settings it always failed with errors below.
Steps To Reproducehttps://build.opensuse.org/package/show/home:X0F:branches:multimedia/ardour
Additional Information[ 636s] clang version 10.0.0
[ 636s] Target: x86_64-unknown-linux-gnu
[ 636s] Thread model: posix
[ 636s] InstalledDir: /usr/bin
[ 636s] Found candidate GCC installation: /usr/bin/../lib64/gcc/x86_64-suse-linux/10
[ 636s] Found candidate GCC installation: /usr/lib64/gcc/x86_64-suse-linux/10
[ 636s] Selected GCC installation: /usr/bin/../lib64/gcc/x86_64-suse-linux/10
[ 636s] Candidate multilib: .;@m64
[ 636s] Selected multilib: .;@m64
[ 636s] (in-process)
[ 636s] "/usr/bin/clang-10.0.0" -cc1 -triple x86_64-unknown-linux-gnu -emit-llvm-bc -flto=thin -flto-unit -disable-free -disable-llvm-verifier -discard-value-names -main-file-name session_state.cc -mrelocation-model pic -pic-level 2 -mthread-model posix -mframe-pointer=none -menable-no-infs -menable-no-nans -menable-unsafe-fp-math -fno-signed-zeros -mreassociate -freciprocal-math -ffp-contract=fast -fno-rounding-math -ffast-math -ffinite-math-only -masm-verbose -mconstructor-aliases -munwind-tables -target-cpu x86-64 -target-feature +mmx -target-feature +3dnow -dwarf-column-info -fno-split-dwarf-inlining -debugger-tuning=gdb -v -resource-dir /usr/lib64/clang/10.0.0 -I /home/abuild/rpmbuild/BUILD/ardour-6.2+21~git20200713T214504 -I /usr/include/qm-dsp -D HAVE_RF64_RIFF -D WAF_BUILD -D NDEBUG -D ARCH_X86 -D BUILD_SSE_OPTIMIZATIONS -D LXVST_64BIT -D BOOST_SYSTEM_NO_DEPRECATED -D _ISOC9X_SOURCE -D _LARGEFILE64_SOURCE -D _FILE_OFFSET_BITS=64 -D "PROGRAM_NAME=\"Ardour\"" -D "PROGRAM_VERSION=\"6\"" -D BOOST_NO_AUTO_PTR -D __STDC_LIMIT_MACROS -D __STDC_FORMAT_MACROS -D CANVAS_COMPATIBILITY -D CANVAS_DEBUG -D BOOST_ERROR_CODE_HEADER_ONLY -F/System/Library/Frameworks -F/Library/Frameworks -I libs/ardour -I ../libs/ardour -I libs/surfaces/control_protocol -I ../libs/surfaces/control_protocol -I libs -I ../libs -I libs/midi++2 -I ../libs/midi++2 -I libs/evoral -I ../libs/evoral -I libs/audiographer -I ../libs/audiographer -I libs/audiographer/src -I ../libs/audiographer/src -I libs/ptformat -I ../libs/ptformat -I libs/pbd -I ../libs/pbd -I libs/evoral/libsmf -I ../libs/evoral/libsmf -I libs/temporal -I ../libs/temporal -I libs/lua -I ../libs/lua -I libs/zita-resampler -I ../libs/zita-resampler -I libs/zita-convolver -I ../libs/zita-convolver -I /usr/include/glibmm-2.4 -I /usr/lib64/glibmm-2.4/include -I /usr/include/glib-2.0 -I /usr/lib64/glib-2.0/include -I /usr/include/sigc++-2.0 -I /usr/lib64/sigc++-2.0/include -I /usr/include/libxml2 -I /usr/include/raptor2 -I /usr/include/giomm-2.4 -I /usr/lib64/giomm-2.4/include -I /usr/include/libmount -I /usr/include/blkid -I /usr/include/taglib -I /usr/include/lilv-0 -I /usr/include/serd-0 -I /usr/include/sord-0 -I /usr/include/sratom-0 -I /usr/include/suil-0 -I /home/abuild/rpmbuild/BUILD/ardour-6.2+21~git20200713T214504/build -D INTERNAL_SHARED_LIBS=1 -D USE_EXTERNAL_LIBS=1 -D HAVE_ALSA=1 -D HAVE_PULSEAUDIO=1 -D HAVE_GLIB=1 -D HAVE_GTHREAD=1 -D HAVE_GLIBMM=1 -D HAVE_SNDFILE=1 -D HAVE_GIOMM=1 -D HAVE_CURL=1 -D HAVE_ARCHIVE=1 -D HAVE_LO=1 -D HAVE_TAGLIB=1 -D HAVE_VAMPSDK=1 -D HAVE_VAMPHOSTSDK=1 -D HAVE_RUBBERBAND=1 -D EXPORT_VISIBILITY_HIDDEN=0 -D ENABLE_NLS=1 -D LXVST_SUPPORT=1 -D HAVE_JACK=1 -D "CONFIG_ARCH=\"x86_64\"" -D HAVE_TOOLS_SANITY_CHECK=1 -D HAVE_TOOLS_GCCABICHECK=1 -D HAVE_LIBS_CLEARLOOKS_NEWER=1 -D HAVE_LIBFLUIDSYNTH=1 -D HAVE_LIBS_FLUIDSYNTH=1 -D HAVE_HIDAPI=1 -D HAVE_LIBS_HIDAPI=1 -D HAVE_LIBLTC=1 -D HAVE_LIBS_LIBLTC=1 -D HAVE_LIBS_LUA=1 -D HAVE_LIBS_PTFORMAT=1 -D HAVE_BASE_PITCH_H=1 -D HAVE_LIBS_QM_DSP=1 -D HAVE_FFTW3F=1 -D HAVE_AUBIO=1 -D HAVE_AUBIO4=1 -D HAVE_LIBS_VAMP_PLUGINS=1 -D HAVE_LIBS_VAMP_PYIN=1 -D HAVE_LIBS_ZITA_RESAMPLER=1 -D HAVE_LIBS_ZITA_CONVOLVER=1 -D HAVE_XML=1 -D HAVE_SIGCPP=1 -D HAVE_EXECINFO=1 -D HAVE_POSIX_MEMALIGN=1 -D HAVE_GETMNTENT=1 -D HAVE_LOCALTIME_R=1 -D HAVE_LIBS_PBD=1 -D HAVE_CPPUNIT=1 -D HAVE_LIBS_MIDIPP2=1 -D HAVE_LIBS_EVORAL=1 -D HAVE_USB=1 -D HAVE_CWIID_H=1 -D HAVE_BLUETOOTH_H=1 -D HAVE_CWIID=1 -D BUILD_WIIMOTE=1 -D HAVE_WEBSOCKETS=1 -D HAVE_CONTROL_PROTOCOL=1 -D HAVE_FADERPORT=1 -D HAVE_FADERPORT8=1 -D HAVE_CC121=1 -D HAVE_GENERIC_MIDI=1 -D HAVE_MACKIE=1 -D HAVE_US2400=1 -D HAVE_LAUNCH_CONTROL_XL=1 -D HAVE_PANGOMM=1 -D HAVE_CAIROMM=1 -D HAVE_PUSH2=1 -D HAVE_CONTOURDESIGN=1 -D HAVE_WIIMOTE=1 -D HAVE_LIBS_SURFACES=1 -D HAVE_2IN2OUT=1 -D HAVE_1IN2OUT=1 -D HAVE_VBAP=1 -D HAVE_STEREOBALANCE=1 -D HAVE_LIBS_PANNERS=1 -D HAVE_DUMMY=1 -D HAVE_JACK_METADATA=1 -D HAVE_LIBS_BACKENDS=1 -D HAVE_LIBS_TEMPORAL=1 -D HAVE_LRDF=1 -D HAVE_SAMPLERATE=1 -D HAVE_LV2=1 -D HAVE_LV2_1_10_0=1 -D HAVE_LV2_1_17_2=1 -D HAVE_SERD=1 -D HAVE_SORD=1 -D HAVE_SRATOM=1 -D HAVE_LILV=1 -D HAVE_SUIL=1 -D LV2_SUPPORT=1 -D LV2_EXTENDED=1 -D HAVE_OGG=1 -D HAVE_FLAC=1 -D HAVE_FFTW35F=1 -D USE_RUBBERBAND=1 -D CURRENT_SESSION_FILE_VERSION=6000 -D HAVE_SYS_VFS_H=1 -D HAVE_SYS_STATVFS_H=1 -D HAVE_UNISTD=1 -D HAVE_BOOST_SCOPED_PTR_HPP=1 -D HAVE_BOOST_PTR_CONTAINER_PTR_LIST_HPP=1 -D HAVE_LIBS_ARDOUR=1 -D HAVE_GTKMM=1 -D HAVE_GTK=1 -D HAVE_LIBS_GTKMM2EXT=1 -D HAVE_BOOST_FORMAT_HPP=1 -D HAVE_LIBS_AUDIOGRAPHER=1 -D HAVE_LIBS_CANVAS=1 -D HAVE_LIBS_WIDGETS=1 -D HAVE_LIBS_WAVEVIEW=1 -D HAVE_LV2_1_0_0=1 -D HAVE_LIBS_PLUGINS_REASONABLESYNTH_LV2=1 -D HAVE_CAIRO=1 -D HAVE_LIBS_PLUGINS_A_COMP_LV2=1 -D HAVE_LIBS_PLUGINS_A_EXP_LV2=1 -D HAVE_LIBS_PLUGINS_A_DELAY_LV2=1 -D HAVE_LIBS_PLUGINS_A_EQ_LV2=1 -D HAVE_LIBS_PLUGINS_A_REVERB_LV2=1 -D HAVE_LIBS_PLUGINS_A_FLUIDSYNTH_LV2=1 -D HAVE_X11=1 -D HAVE_PANGOFT2=1 -D HAVE_FONTCONFIG=1 -D HAVE_BOOST_SHARED_PTR_HPP=1 -D HAVE_BOOST_WEAK_PTR_HPP=1 -D HAVE_GTK2_ARDOUR=1 -D HAVE_SHARE_EXPORT=1 -D HAVE_SHARE_MIDI_MAPS=1 -D HAVE_SHARE_MCP=1 -D HAVE_SHARE_OSC=1 -D HAVE_SHARE_PATCHFILES=1 -D HAVE_SHARE_PLUGIN_METADATA=1 -D HAVE_SHARE_SCRIPTS=1 -D HAVE_SHARE_WEB_SURFACES=1 -D HAVE_HEADLESS=1 -D HAVE_LUASESSION=1 -D HAVE_SESSION_UTILS=1 -D HAVE_LIBS_FST=1 -D HAVE_LIBS_VFORK=1 -D HAVE_DBUS=1 -D HAVE_LIBS_ARDOURALSAUTIL=1 -D LIBARDOUR_DLL_EXPORTS=1 -D "PACKAGE=\"ardour6\"" -D "DATA_DIR=\"/usr/share/ardour6\"" -D "CONFIG_DIR=\"/etc\"" -D "LOCALEDIR=\"/usr/share/ardour6/locale\"" -D "LIBARDOUR=\"ardour6\"" -D LXVST_SUPPORT -internal-isystem /usr/bin/../lib64/gcc/x86_64-suse-linux/10/../../../../include/c++/10 -internal-isystem /usr/bin/../lib64/gcc/x86_64-suse-linux/10/../../../../include/c++/10/x86_64-suse-linux -internal-isystem /usr/bin/../lib64/gcc/x86_64-suse-linux/10/../../../../include/c++/10/backward -internal-isystem /usr/local/include -internal-isystem /usr/lib64/clang/10.0.0/include -internal-externc-isystem /include -internal-externc-isystem /usr/include -O3 -Wall -Wpointer-arith -Wcast-qual -Wcast-align -Wno-unused-parameter -Woverloaded-virtual -Wno-mismatched-tags -Wno-cast-align -Wno-unused-local-typedefs -Wunneeded-internal-declaration -w -std=c++11 -fdeprecated-macro -fdebug-compilation-dir /home/abuild/rpmbuild/BUILD/ardour-6.2+21~git20200713T214504/build -ferror-limit 19 -fmessage-length 0 -pthread -fgnuc-version=4.2.1 -fobjc-runtime=gcc -fcxx-exceptions -fexceptions -fdiagnostics-show-option -vectorize-loops -vectorize-slp -faddrsig -o /home/abuild/rpmbuild/BUILD/ardour-6.2+21~git20200713T214504/build/libs/ardour/session_state.cc.1.o -x c++ ../libs/ardour/session_state.cc
[ 636s] clang -cc1 version 10.0.0 based upon LLVM 10.0.0 default target x86_64-unknown-linux-gnu
[ 636s] ignoring nonexistent directory "/System/Library/Frameworks"
[ 636s] ignoring nonexistent directory "/Library/Frameworks"
[ 636s] ignoring nonexistent directory "/include"
[ 636s] #include "..." search starts here:
[ 636s] #include <...> search starts here:
[ 636s] /home/abuild/rpmbuild/BUILD/ardour-6.2+21~git20200713T214504
[ 636s] /usr/include/qm-dsp
[ 636s] libs/ardour
[ 636s] ../libs/ardour
[ 636s] libs/surfaces/control_protocol
[ 636s] ../libs/surfaces/control_protocol
[ 636s] libs
[ 636s] ../libs
[ 636s] libs/midi++2
[ 636s] ../libs/midi++2
[ 636s] libs/evoral
[ 636s] ../libs/evoral
[ 636s] libs/audiographer
[ 636s] ../libs/audiographer
[ 636s] libs/audiographer/src
[ 636s] ../libs/audiographer/src
[ 636s] libs/ptformat
[ 636s] ../libs/ptformat
[ 636s] libs/pbd
[ 636s] ../libs/pbd
[ 636s] libs/evoral/libsmf
[ 636s] ../libs/evoral/libsmf
[ 636s] libs/temporal
[ 636s] ../libs/temporal
[ 636s] libs/lua
[ 636s] ../libs/lua
[ 636s] libs/zita-resampler
[ 636s] ../libs/zita-resampler
[ 636s] libs/zita-convolver
[ 636s] ../libs/zita-convolver
[ 636s] /usr/include/glibmm-2.4
[ 636s] /usr/lib64/glibmm-2.4/include
[ 636s] /usr/include/glib-2.0
[ 636s] /usr/lib64/glib-2.0/include
[ 636s] /usr/include/sigc++-2.0
[ 636s] /usr/lib64/sigc++-2.0/include
[ 636s] /usr/include/libxml2
[ 636s] /usr/include/raptor2
[ 636s] /usr/include/giomm-2.4
[ 636s] /usr/lib64/giomm-2.4/include
[ 636s] /usr/include/libmount
[ 636s] /usr/include/blkid
[ 636s] /usr/include/taglib
[ 636s] /usr/include/lilv-0
[ 636s] /usr/include/serd-0
[ 636s] /usr/include/sord-0
[ 636s] /usr/include/sratom-0
[ 636s] /usr/include/suil-0
[ 636s] /home/abuild/rpmbuild/BUILD/ardour-6.2+21~git20200713T214504/build
[ 636s] /usr/bin/../lib64/gcc/x86_64-suse-linux/10/../../../../include/c++/10
[ 636s] /usr/bin/../lib64/gcc/x86_64-suse-linux/10/../../../../include/c++/10/x86_64-suse-linux
[ 636s] /usr/bin/../lib64/gcc/x86_64-suse-linux/10/../../../../include/c++/10/backward
[ 636s] /usr/local/include
[ 636s] /usr/lib64/clang/10.0.0/include
[ 636s] /usr/include
[ 636s] End of search list.
[ 636s] In file included from ../libs/ardour/session_state.cc:107:
[ 636s] In file included from ../libs/ardour/ardour/graph.h:33:
[ 636s] ../libs/pbd/pbd/mpmc_queue.h:91:9: error: cannot initialize a parameter of type 'guint *' (aka 'unsigned int *') with an rvalue of type 'gint *' (aka 'int *')
[ 636s] if (g_atomic_int_compare_and_exchange (&_enqueue_pos, pos, pos + 1)) {
[ 636s] ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[ 636s] /usr/include/glib-2.0/glib/gatomic.h:159:44: note: expanded from macro 'g_atomic_int_compare_and_exchange'
[ 636s] __atomic_compare_exchange_n ((atomic), &gaicae_oldval, (newval), FALSE, __ATOMIC_SEQ_CST, __ATOMIC_SEQ_CST) ? TRUE : FALSE; \
[ 636s] ^~~~~~~~~~~~~~
[ 636s] In file included from ../libs/ardour/session_state.cc:107:
[ 636s] In file included from ../libs/ardour/ardour/graph.h:33:
[ 636s] ../libs/pbd/pbd/mpmc_queue.h:91:9: error: value of type 'void' is not contextually convertible to 'bool'
[ 636s] if (g_atomic_int_compare_and_exchange (&_enqueue_pos, pos, pos + 1)) {
[ 636s] ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[ 636s] /usr/include/glib-2.0/glib/gatomic.h:155:3: note: expanded from macro 'g_atomic_int_compare_and_exchange'
[ 636s] (G_GNUC_EXTENSION ({ \
[ 636s] ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[ 636s] In file included from ../libs/ardour/session_state.cc:107:
[ 636s] In file included from ../libs/ardour/ardour/graph.h:33:
[ 636s] ../libs/pbd/pbd/mpmc_queue.h:117:9: error: cannot initialize a parameter of type 'guint *' (aka 'unsigned int *') with an rvalue of type 'gint *' (aka 'int *')
[ 636s] if (g_atomic_int_compare_and_exchange (&_dequeue_pos, pos, pos + 1)) {
[ 636s] ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[ 636s] /usr/include/glib-2.0/glib/gatomic.h:159:44: note: expanded from macro 'g_atomic_int_compare_and_exchange'
[ 636s] __atomic_compare_exchange_n ((atomic), &gaicae_oldval, (newval), FALSE, __ATOMIC_SEQ_CST, __ATOMIC_SEQ_CST) ? TRUE : FALSE; \
[ 636s] ^~~~~~~~~~~~~~
[ 636s] In file included from ../libs/ardour/session_state.cc:107:
[ 636s] In file included from ../libs/ardour/ardour/graph.h:33:
[ 636s] ../libs/pbd/pbd/mpmc_queue.h:117:9: error: value of type 'void' is not contextually convertible to 'bool'
[ 636s] if (g_atomic_int_compare_and_exchange (&_dequeue_pos, pos, pos + 1)) {
[ 636s] ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[ 636s] /usr/include/glib-2.0/glib/gatomic.h:155:3: note: expanded from macro 'g_atomic_int_compare_and_exchange'
[ 636s] (G_GNUC_EXTENSION ({ \
[ 636s] ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[ 636s] 4 errors generated.
TagsNo tags attached.

Activities

x42

2020-07-16 11:08

administrator   ~0024744

That seems to be an issue with glib + clang on your system.
Can you compile it with gcc? does updating libglib help?

fox

2020-07-16 13:03

reporter   ~0024745

>Can you compile it with gcc?

Nope !

> does updating libglib help?

It's 2.64.4, released just 2 weeks ago. SUSE hasn't updated to 2.65.x yet for some reason. But it's too big of a system dependency to try packaging around official repository. If you could confirm if that would surely help then I could try, otherwise have to wait to official package. Pretty sure that this was also happening before 2.65.0 was released a month ago, so glib version should not matter unless Ardour have been relying on glib snapshots without defining them in its build-scripts.

PS: damn tracker have nuked previous version of this post with "APPLICATION ERROR 0002800: Invalid form security token. This could be caused by a session timeout, or accidentally submitting the form twice.". It seems it has session timeout per opened page which exist for writing detailed messages but no auto-save (like in github or gitlab)… "great"…

x42

2020-07-16 14:15

administrator   ~0024746

Can you try Ardour 6.2-23-g6d950d15ba ?

We're still using glib 2.42.0, which may be less picky to int/unsigned int atomics.

paul

2020-07-16 14:18

administrator   ~0024747

ps. re the tracker issue, if you google search this, it's been a mantis issue for more than a decade. It is unclear to me what the correct solution is. If you have any input, I'd welcome it.

fox

2020-07-16 15:31

reporter   ~0024748

> Can you try Ardour 6.2-23-g6d950d15ba ?
> We're still using glib 2.42.0, which may be less picky to int/unsigned int atomics.

Now I've got similar errors in ../libs/ardour/session.cc

> ps. re the tracker issue, if you google search this, it's been a mantis issue for more than a decade. It is unclear to me what the correct solution is. If you have any input, I'd welcome it.

Personally, I'd be just migrating to a gitlab instance which seems to have gone very well for freedesktop.org (well, the end result did, the process was long and… arduous). In comparison things like Bugzilla look embarrassing nowadays. That could even facilitate obsolescence of clunky mailing lists.

ardour_6.2+23~git20200716T161321.log (11,529 bytes)

paul

2020-07-16 15:59

administrator   ~0024750

i don't find the gitlab tracker to offer any features that would benefit us vs. mantis *except* for (probably) not having this bug.

we don't have any mailing lists related to the tracker/bugs/feature requests, either.

x42

2020-07-16 16:10

administrator   ~0024751

OK next fix for signed/unsigned atomics in Ardour 6.2-27-g9fcb51de2e

PS. I have a strong dislike for gitlab's tracker (and gitlab's UI in general). besides it's even more overkill that mantis for our purpose.
Currently I hope we can migrate to gitea.io at some point in the future.

fox

2020-07-16 18:40

reporter   ~0024752

Yep, after these changes it finally compiled !
Actually, it also failed with:
[ 2425s] In file included from ../libs/surfaces/websockets/ardour_websockets.cc:30:
[ 2425s] In file included from ../libs/surfaces/websockets/ardour_websockets.h:39:
[ 2425s] In file included from ../libs/surfaces/websockets/server.h:24:
[ 2425s] /usr/include/libwebsockets.h:250:10: fatal error: 'openssl/ssl.h' file not found
But after adding openssl-devel into the build container, it finished successfully. Seems configuration script doesn't check it correctly.

As for issue/development tracker, yeah, I guess whole gitlab instance would only make sense if there are at least several sub-projects and/or constant development discussions in emails, IMs, conferences and forums.

x42

2020-07-16 19:46

administrator   ~0024754

OK. That depends on how libwebsockets was compiled. It may be a distro-bug `pkg-config --libs libwebsockets` should include -lssl etc, if LWS as compiled with SSL support.

Also do a runtime check, you may run into "check your libwebsockets was compiled with LWS_WITH_GLIB or LWS_WITH_EXTERNAL_POLL enabled" in the Ardour-Menu > Window > Log.

x42

2020-07-16 19:47

administrator   ~0024755

fixed in Ardour 6.2-27-g9fcb51de2e

fox

2020-07-16 19:56

reporter   ~0024756

Can't check runtime for now but build log shows enabled SSL, disabled GLIB and no mention of EXTERNAL_POLL: https://build.opensuse.org/package/show/openSUSE%3AFactory/libwebsockets

libwebsockets-4.0.1-1.2.log (418,516 bytes)

Issue History

Date Modified Username Field Change
2020-07-16 02:47 fox New Issue
2020-07-16 11:08 x42 Note Added: 0024744
2020-07-16 13:03 fox Note Added: 0024745
2020-07-16 14:15 x42 Note Added: 0024746
2020-07-16 14:18 paul Note Added: 0024747
2020-07-16 15:31 fox File Added: ardour_6.2+23~git20200716T161321.log
2020-07-16 15:31 fox Note Added: 0024748
2020-07-16 15:59 paul Note Added: 0024750
2020-07-16 16:10 x42 Note Added: 0024751
2020-07-16 18:40 fox Note Added: 0024752
2020-07-16 19:46 x42 Note Added: 0024754
2020-07-16 19:47 x42 Assigned To => x42
2020-07-16 19:47 x42 Status new => resolved
2020-07-16 19:47 x42 Resolution open => fixed
2020-07-16 19:47 x42 Note Added: 0024755
2020-07-16 19:56 fox File Added: libwebsockets-4.0.1-1.2.log
2020-07-16 19:56 fox Note Added: 0024756