View Issue Details

IDCategoryLast Update
0008297features2020-09-07 14:33
Reporteriur.nAssigned Tox42 
ReproducibilityN/A 
Status closedResolutionfixed 
Product Version6.0 
Fixed in Version 
Summary0008297: Add double click to maximize / minimize the track
DescriptionI think it would more easy to maximize/minimize the track when in additional to key F to add double click on the track control area. Of course, there is also an action connected to this "edit track name"... but there is enough space to double-click to have also this feature. I have implemented this in the axis_ view class and for me it works. It is easier now to maximize/minimize tracks.

At the moment to maximize a track you need to select it and than press F. The user needs two actions and more effort. Adding also the double click it reduces the number of actions and user attention remains on the screen.

If you think this is a good feature. I can put more time to implement it maybe more properly with your guide.
TagsNo tags attached.

Activities

paul

2020-07-11 03:27

administrator   ~0024686

post a pull request or a patch and we'll take a look.

we're fairly focused on the idea that efficient use of a DAW requires combined mouse+keyboard operations, and i would argue strongly with anyone who disputes this. but that doesn't mean we can't make mouse-only operation more powerful/useful.

iur.n

2020-07-11 06:22

reporter   ~0024690

"efficient use of a DAW requires combined mouse+keyboard operations", I agree with this. I didn't meant to remove any shortcuts, just add additional functionality with mouse.
Ok, I make a pull request.

iur.n

2020-07-11 09:00

reporter   ~0024693

Added the pull request on Github: https://github.com/Ardour/ardour/pull/536

Double click to expand / contract the track. When is minimized I set it to normal height. Ideally to be able to set it to small height. But small height has little area that is not related to name editing.

Ideally I would like double click to do this:

Return the track to smallest height, or make it maximum (the same as F shortcut is doing for expansion).

Proposal: maybe to add more space to the track header or left side, so there will be easy to double click when the track is small

mhartzel

2020-07-11 11:28

reporter   ~0024695

Ideally the previous height of the track would be stored when maximizing and restored when unmaximized.

I also liked to have this feature implemented, because I need it in this workflow: When I start mixing I want to have all of my tracks visible (say 20 tracks). Then I play the session and when I hear that a spot on a track needs fixing (say a border of a region needs adjusting / fading, or I need to make some region volume changes) I make the track full size while editing and then I want it to go back to the exact size it was so I can still see all my 20 tracks.

mhartzel

2020-07-11 11:39

reporter   ~0024696

Imho it would be more convenient if the keybord shortcut "f" that now zooms a select track to full size would toggle back to the previous zoom level on second press. Then all that was needed to go into detailed edit mode on a track was a single press of f and another to restore the previous zoom level.

Doing the same with the mouse requires one to first move the pointer on a track header, then a double click on a specific spot. Then you need to move your mouse pointer back on the spot that needs editing. Then another mouse pointer move back to the track header and a double click.

It would be much faster to do track zoom toggling with a single key press.

iur.n

2020-07-11 12:32

reporter   ~0024697

@mhartzel
"Ideally the previous height of the track would be stored when maximizing and restored when unmaximized."
Yes, the first time I made the implementation like you mentioned because is a kind of natural order of actions.
 But in time by editing tracks "due to the entropy" the user will gete the same "chaos" regarding tracks height, and will need to resize
 all the tracks back to minimum height in order to see the song arrangement.

I am struggling which the same problem as you - I need to see all or most of the arrangement visually on the screen.

paul

2020-07-11 14:25

administrator   ~0024701

do you allow know about visual undo (Shift-z) ? it's not the same as a "previous-height" being stored for each individual track, but in the "make track fill window; now go back to seeing everything" workflow, it's more or less equivalent.

paul

2020-07-11 14:27

administrator   ~0024702

also, the little "show N tracks" widget over toward the right edge of the toolbar, which can be clicked and set to "All", which will reduce all tracks the minimum height required to show all (or the maximum) number of tracks, limited to the "default" track height. next to it is "shrink tracks" which will make them the minimum possible size.

mhartzel

2020-07-11 15:19

reporter   ~0024703

I have "Fit All Tracks" tied to keyboard shortcut 'a' and now I can zoom the selected track to full with 'f' and get zoom level to all tracks by pressing 'a'. This works nicely if you don't have lots of tracks (30+).

If shortcut 'f' would toggle selected track to full and back to previous editor window zoom level, then you would be able to have say 10 tracks of a 50 track session fill the edit window and zoom to a single track and back to seeing just the 10 tracks with one key press. A workflow where one could use this would be for example when doing some work only on the 10 drum tracks of a 50 track session.

x42

2020-07-12 14:13

administrator   ~0024717

https://github.com/Ardour/ardour/pull/536 was merged as Ardour 6.2-15
Can this be closed, or is there more to come?

iur.n

2020-07-12 15:16

reporter   ~0024720

Thank you! :) For now I think can be closed. There will be more but for other issues.

anonymous

2020-09-07 14:33

viewer   ~0025016

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-07-09 14:33 iur.n New Issue
2020-07-11 03:27 paul Note Added: 0024686
2020-07-11 06:22 iur.n Note Added: 0024690
2020-07-11 09:00 iur.n Note Added: 0024693
2020-07-11 11:28 mhartzel Note Added: 0024695
2020-07-11 11:39 mhartzel Note Added: 0024696
2020-07-11 12:32 iur.n Note Added: 0024697
2020-07-11 14:25 paul Note Added: 0024701
2020-07-11 14:27 paul Note Added: 0024702
2020-07-11 15:19 mhartzel Note Added: 0024703
2020-07-12 14:13 x42 Note Added: 0024717
2020-07-12 14:13 x42 Assigned To => x42
2020-07-12 14:13 x42 Status new => feedback
2020-07-12 15:16 iur.n Note Added: 0024720
2020-07-12 15:16 iur.n Status feedback => assigned
2020-07-12 18:28 paul Status assigned => resolved
2020-07-12 18:28 paul Resolution open => fixed
2020-09-07 14:33 anonymous Note Added: 0025016
2020-09-07 14:33 anonymous Status resolved => closed