View Issue Details

IDCategoryLast Update
0008280bugs2020-07-11 17:23
ReportersamthursfieldAssigned Topaul 
Reproducibilityalways 
Status resolvedResolutionno change required 
PlatformRedhatOSLinuxOS Version(any)
Product Version6.0 
Fixed in Version 
Summary0008280: Plugin presets can be saved but not loaded, with default configuration
DescriptionSaving presets for LV2 plugins works as expected (they appear in my ~/.lv2) folder, but after restarting ardour6 none of the saved presets appear in the preset list.

The forum comment at https://discourse.ardour.org/t/saving-plugin-presets-programmatically-lua-midi-osc/100482/23 gives a workaround: set LV2_PATH to include $HOME/.lv2 before starting ardour6.

It seems wrong that Ardour saves data by default in a location which it doesn't read by default. Can we change the default LV2_PATH to include `$HOME/.lv2` ?
Steps To ReproduceSteps I took using Ardour 6.0.0 on Fedora 32, built from the source tarball:

1. Start ardour6, create a project, create a track and add an LV2 plugin.
2. Save a preset for the plugin.
3. Restart ardour
4. Open the same plugin UI, look in vain for the preset that you saved.

TagsNo tags attached.

Activities

samthursfield

2020-07-10 15:38

reporter   ~0024675

This can be worked around as described here: https://discourse.gnome.org/t/how-to-set-an-environment-variable-when-starting-an-application/3724/4

paul

2020-07-11 03:30

administrator   ~0024688

Your problem would not occur with the build of ardour from ardour.org

It is caused by using a version of liblv on your system that wasn't compiled to search in ~/.lv2. The version used in the official build does this correctly.

samthursfield

2020-07-11 14:18

reporter   ~0024699

Thanks for the information. I'm using Fedora 32 so I guess a change is needed in the Fedora package. I'll open an issue there instead.

paul

2020-07-11 14:19

administrator   ~0024700

see notes.

samthursfield

2020-07-11 17:23

reporter   ~0024706

Here's the relevant issue in Fedora's bug tracker: https://bugzilla.redhat.com/show_bug.cgi?id=1856001

Issue History

Date Modified Username Field Change
2020-07-02 20:40 samthursfield New Issue
2020-07-10 15:38 samthursfield Note Added: 0024675
2020-07-11 03:30 paul Note Added: 0024688
2020-07-11 14:18 samthursfield Note Added: 0024699
2020-07-11 14:19 paul Assigned To => paul
2020-07-11 14:19 paul Status new => resolved
2020-07-11 14:19 paul Resolution open => no change required
2020-07-11 14:19 paul Note Added: 0024700
2020-07-11 17:23 samthursfield Note Added: 0024706