View Issue Details

IDCategoryLast Update
0008251bugs2020-06-17 06:21
ReporterinFlowiaLabAssigned To 
Reproducibilitysometimes 
Status feedbackResolutionreopened 
PlatformLinuxOSUbuntu StudioOS Version19.10 x64
Product Version6.0 
Fixed in Version 
Summary0008251: 3 SF2 samplers stop working after restarting Ardour.
DescriptionGeneral-MIDI Synth,
Calf FluidSynth
and a-FluidSynth -
Sometimes they break and stop making any sound until you remove the plugin from the track and add it again. That is, after each restart Ardour has to do this - remove the plugin and add it again, otherwise it will not make a sound, although it is clear that MIDI keys come to it. Most often this happens when using SF2 from General-MIDI Sint with the "Pan Flute" instrument, but it also happened with other instruments.
Moreover, it seems that something is breaking down not in the sampler but in the track itself, because even if you choose any other of the 3 listed instead of one sampler, it will behave in exactly the same way. Duplicating a track does not help. Taking a track will have the same problems.

I'm already doing the 2nd project in Ardor 6 and this happens again.
Tagslv2, Midi, plugin, track

Activities

x42

2020-06-16 22:07

administrator   ~0024478

Could it be that you send CC7 messages to the track? that lowers the volume and the synth remains silent. Ardour MIDI tracks remember and restore Control Changes.

Easiest to see by in the editor. use the "A"utomation button > Controllers > Channel Volume
Next time this happens, check if manually increasing it returns the sound.

inFlowiaLab

2020-06-17 05:23

reporter   ~0024479

Thank you) It really was "Channel Volume" = 0. I changed it manually and the tracks began to work normally even after a restart.

inFlowiaLab

2020-06-17 06:21

reporter   ~0024480

Although this is not normal behavior at all: I remove the plugin, add it again and everything works fine, the sound goes on, although the channel volume is still = 0. I think it needs to be fixed.

Issue History

Date Modified Username Field Change
2020-06-16 12:16 inFlowiaLab New Issue
2020-06-16 12:16 inFlowiaLab Tag Attached: lv2
2020-06-16 12:16 inFlowiaLab Tag Attached: Midi
2020-06-16 12:16 inFlowiaLab Tag Attached: plugin
2020-06-16 12:16 inFlowiaLab Tag Attached: track
2020-06-16 22:07 x42 Note Added: 0024478
2020-06-17 05:23 inFlowiaLab Note Added: 0024479
2020-06-17 05:24 inFlowiaLab Status new => closed
2020-06-17 05:24 inFlowiaLab Resolution open => no change required
2020-06-17 06:21 inFlowiaLab Status closed => feedback
2020-06-17 06:21 inFlowiaLab Resolution no change required => reopened
2020-06-17 06:21 inFlowiaLab Note Added: 0024480