View Issue Details

IDProjectCategoryView StatusLast Update
0008227ardourbugspublic2022-10-22 18:48
Reporterderwok Assigned To 
Status newResolutionopen 
PlatformThinkpad T460sOSUbuntu LinuxOS Version20.04 LTS
Product Version6.0 
Summary0008227: Ardour 6.0.0 crashes on session load
DescriptionUsing Ardour 6.0.0 on Ubuntu 20.04 LTS. With ALSA drivers (No Jack).
Worked on this session for several days. It survived multiple opens/closes.
Neither Sound nor MIDI setup changed in theses days.

Now loading my session gives me a loading error (see screenshot) with Ardour crash after pressing OK.
Steps To ReproduceLoad the attached session file (sorry only XML, no audio / midi)
Additional InformationI tried:

    Check other sessions. OK: All my other stored project’s sessions load great without a hic-up. Some more complex, some less complex as this one…
    I rebooted. No help
    I unpluged all devices. Then replugged all devices. At no avail…
    I tried to load the session “Safe Mode: Disable all plugins”
    I tried to create a new session: OK, works

Console log follows:

wok@thinkpad:~$ Ardour6
Ardour6.0.0 (built using 6.0 and GCC version 6.3.0 20170516)
Ardour: [INFO]: Your system is configured to limit Ardour to 1048576 open files
Ardour: [INFO]: Loading system configuration file /opt/Ardour-6.0.0/etc/system_config
Ardour: [INFO]: Loading user configuration file /home/wok/.config/ardour6/config
Ardour: [INFO]: CPU vendor: GenuineIntel
Ardour: [INFO]: AVX-capable processor
Ardour: [INFO]: CPU brand: Intel(R) Core(TM) i7-6600U CPU @ 2.60GHz
Ardour: [INFO]: Using SSE optimized routines
Ardour: [INFO]: Loading plugin meta data file /opt/Ardour-6.0.0/share/plugin_metadata/plugin_tags
Ardour: [INFO]: Loading plugin meta data file /home/wok/.config/ardour6/plugin_metadata/plugin_tags
Cannot xinstall SIGPIPE error handler
Ardour: [INFO]: Loading default ui configuration file /opt/Ardour-6.0.0/etc/default_ui_config
Ardour: [INFO]: Loading user ui configuration file /home/wok/.config/ardour6/ui_config
Ardour: [INFO]: Loading 449 MIDI patches from /opt/Ardour-6.0.0/share/patchfiles
Gtk-Message: Failed to load module "canberra-gtk-module"
Ardour: [INFO]: Loading color file /opt/Ardour-6.0.0/share/themes/dark-ardour.colors
Ardour: [INFO]: Loading ui configuration file /opt/Ardour-6.0.0/etc/clearlooks.rc
Ardour: [INFO]: Loading bindings from /home/wok/.config/ardour6/ardour.keys
Loading ui configuration file /opt/Ardour-6.0.0/etc/clearlooks.rc
Found nothing along /home/wok/.config/ardour6/templates:/opt/Ardour-6.0.0/share/templates
Scanning folders for bundled LV2s: /opt/Ardour-6.0.0/lib/LV2
Set cursor set to default
 loading from ... templ is_new 0 bp 0
Butler drops pool trash
Log Messages:
INFO: AlsaAudioBackend: adjusted output channel count to match device.
INFO: AlsaAudioBackend: adjusted input channel count to match device.
INFO: harvid version: 803
INFO: Loading menus from /opt/Ardour-6.0.0/etc/ardour.menus
ERROR: Unexpected exception during session setup: tr1::bad_weak_ptr

Tagscrash load bad_weak_ptr


related to 0008911 new Session doesn't load (ERROR: Unexpected exception during session setup: tr1::bad_weak_ptr) 



2020-06-11 18:27


load-error.png (35,124 bytes)   
load-error.png (35,124 bytes)   
Happy Birthday.ardour (269,237 bytes)


2020-06-11 18:55

administrator   ~0024452

Last edited: 2020-06-11 19:30

The attached file allows to load the session again. Replace the "Happy Birthday.ardour" file in your session folder with the file.
The fix is to change line 3075 and disable <code>Protocol name="Generic MIDI" ... active="0"</code>

The bug is caused since you've apparently used MIDI-learn and the Control that was assigned is no longer available (a pitch-bend?). We'll need to address this in a future release.

Happy Birthday-2.ardour (269,237 bytes)


2020-06-11 19:42

reporter   ~0024453

There it is in all its beauty!!
You're my hero!! Big thanx!
(And thanks to the XML format that makes patching so easy) :-)
Never would have thought of this root cause.

But I need to say: yes: I tried to learn the pitch bend. But it did not work out while the session was open. Anyhow it got saved?!
The pitch bend had no effect on the setBfree organ. When I tried to load the (then crashing) session , the MIDI keyboard was all available with the same hardware pitch bend.
So it might be, that the problem is not during loading (the hardware was available and connected!), but that the problem occured even more early during assigning and saving bad information?

Anyway: thanks again! Just out of sheer happiness a photo of Ardour with my session loading again.


2020-06-11 19:57

administrator   ~0024455

Well, organs have no pitch-bend, so it may have been "working", but setBfree does not respond since a Hammond B3 has not pitch-wheel.

Anyway, I'll leave this issue open. The root cause remains to be fixed and that session of yours will come in handy for this.


2020-07-15 16:29

reporter   ~0024742

I just wanted to inform you that I had the same problem with a project today. Setting "Generic MIDI" to active="0" also worked for me. Thanks a lot!


2021-01-03 16:31

reporter   ~0025373

I had the same "tr1::bad_weak_ptr" exception on startup. I had used midi learning and not changed any hardware.

Removing this block made it run again:

$ diff "Pirate#0.ardour.orig" "Pirate#0.ardour.patchfixed"
< <Protocol name="Generic MIDI" feedback="1" feedback-interval="10000" threshold="15" motorized="0" binding="Korg nanoKONTROL Studio" active="1">
< <Input>
< <Port name="MIDI Control In" direction="input">
< <Connection other="system:midi_capture_nanoKONTROL Studio"/>
< </Port>
< </Input>
< <Output>
< <Port name="MIDI Control Out" direction="output">
< <Connection other="system:midi_playback_nanoKONTROL Studio"/>
< </Port>
< </Output>
< <Controls>
< <MIDIControllable id="23059" event="0xb0" channel="0" additional="0xc"/>
< </Controls>
< </Protocol>

Actually if I just remove:
< <Controls>
< <MIDIControllable id="23059" event="0xb0" channel="0" additional="0xc"/>
< </Controls>

...Ardour will load the session. I'm up and running again thanks to finding this bug report.


2021-11-11 18:15

reporter   ~0026214

Phew! This just saved me from a huge headache and the loss of two days work, thanks guys!
Had a setBFree track and assigned my Faderport via QMidiRoute to the rotary speed (which works). Setting <code>Protocol name="Generic MIDI" ... active="0"</code> solved it.

Issue History

Date Modified Username Field Change
2020-06-11 18:27 derwok New Issue
2020-06-11 18:27 derwok Tag Attached: crash load bad_weak_ptr
2020-06-11 18:27 derwok File Added: load-error.png
2020-06-11 18:27 derwok File Added: Happy Birthday.ardour
2020-06-11 18:55 x42 File Added: Happy Birthday-2.ardour
2020-06-11 18:55 x42 Note Added: 0024452
2020-06-11 19:30 x42 Note Edited: 0024452
2020-06-11 19:42 derwok File Added: 2020-06-11_21-36 Ardour Screenshot.png
2020-06-11 19:42 derwok Note Added: 0024453
2020-06-11 19:57 x42 Note Added: 0024455
2020-07-15 16:29 consint Note Added: 0024742
2021-01-03 16:31 kevinw Note Added: 0025373
2021-11-11 18:15 MyLoFy Note Added: 0026214
2022-10-22 18:48 x42 Relationship added related to 0008911