View Issue Details

IDProjectCategoryView StatusLast Update
0008191ardourbugspublic2020-06-06 07:55
ReporterinFlowiaLab Assigned To 
Status newResolutionopen 
PlatformLinuxOSUbuntu StudioOS Version19.10 x64
Product Version6.0 
Summary0008191: Sometimes automation begins to be written as a "comb"
DescriptionSometimes automation starts to be written in the form of a strange "comb", as if the value jumps from 0 until I set it using the MIDI controller knob. Look at the screenshot - it was recorded when I tried to make a sinusoid using the controller of the MIDI controller AKAI MPK mini.

Control surface of the protocol - Generic MIDI
It happens in both touch mode and write mode.
It seems the most reliable way to meet this bug is to set the playback head at the very beginning of the track and write from the very beginning. If you write from the middle, it writes abnormally. Although this is not always the case.



2020-06-02 12:38


automation.png (150,519 bytes)   
automation.png (150,519 bytes)   


2020-06-02 12:42

reporter   ~0024347

I tried different knobs on my MIDI keyboard - there is no difference. The problem is not with hardware.


2020-06-02 12:46

reporter   ~0024348

This happens when recording is not from the beginning, if before starting recording in touch mode, turn the knob so that an automation point is created and begins to move in accordance with the cnob and only after that turn on the transport and start turning the knob to record automation.


2020-06-05 19:51

reporter   ~0024409

I noticed that this happens when I try to record over the old recorded automation, that is, if there are already points on the curve where the recording is going on. If I record areas without points, then everything is fine.


2020-06-05 21:20

administrator   ~0024410

Are you using touch-mode with a control-surface that does not support touch?


2020-06-06 07:45

reporter   ~0024414

Yes, my MIDI controller does not support touching knob, but I already indicated in the first message that:
It happens in both touch mode and WRITE mode.


2020-06-06 07:55

reporter   ~0024415

Moreover. This happens even when recording with the mouse.
Create a new session. Turn on the automation of the fader master track in the WRITE mode, put the playhead at the beginning of the track and press the spacebar. A line at 0dB will be recorded. Then again, switch the playhead to the beginning of the track, go to the WRITE mode of automation and use the mouse to fader to the maximum and press the space bar to start recording. I will eventually record "comb" as in the screenshot.
You can also move the fader with the mouse during recording and the comb will continue to occur. It will stop as soon as the area where the automation was recorded last time ends and the "clean area without a single point of automation, where automation was not written, begins.

Issue History

Date Modified Username Field Change
2020-06-02 12:38 inFlowiaLab New Issue
2020-06-02 12:38 inFlowiaLab Tag Attached: automation
2020-06-02 12:38 inFlowiaLab File Added: automation.png
2020-06-02 12:42 inFlowiaLab Note Added: 0024347
2020-06-02 12:46 inFlowiaLab Note Added: 0024348
2020-06-05 19:51 inFlowiaLab Note Added: 0024409
2020-06-05 21:20 x42 Note Added: 0024410
2020-06-06 07:45 inFlowiaLab Note Added: 0024414
2020-06-06 07:55 inFlowiaLab Note Added: 0024415