View Issue Details

IDCategoryLast Update
0008176bugs2020-07-12 14:30
ReporterinFlowiaLabAssigned To 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformLinuxOSUbuntu StudioOS Version19.10 x64
Product Version6.0 
Fixed in Version 
Summary0008176: "Select all after Edit Point" work incorrectly
DescriptionEither nothing or a couple of regions is selected at the beginning of the track, but it’s definitely not like after the editing point.
Steps To ReproduceSet edit point = playhead, put the playhead in the middle of a track with many MIDI regions. Click "Select all after Edit Point".
Additional InformationIt does not work for any value of the "editing point" parameter. Also, "select everything before the editing point" does not work.
Tagsselect

Activities

paul

2020-07-03 04:21

administrator   ~0024576

It works as expected if you are not using draw or internal edit mode. If you are in that mode, it is ambiguous what you want to select, since for the most part, Ardour's MIDI editing happens per-region (though less so these days, so that might be relaxable).

inFlowiaLab

2020-07-12 14:30

reporter   ~0024719

Now it works.

Issue History

Date Modified Username Field Change
2020-05-31 20:38 inFlowiaLab New Issue
2020-05-31 20:38 inFlowiaLab Tag Attached: select
2020-07-03 04:21 paul Note Added: 0024576
2020-07-12 14:30 inFlowiaLab Status new => closed
2020-07-12 14:30 inFlowiaLab Resolution open => fixed
2020-07-12 14:30 inFlowiaLab Note Added: 0024719