View Issue Details

IDCategoryLast Update
0008166other2020-07-29 10:28
Reporterjohne53Assigned Topaul 
ReproducibilityN/A 
Status closedResolutionfixed 
PlatformWindows 10OSWindowsOS Version10
Product VersionMixbus 6.x 
Fixed in Version 
Summary0008166: Zita stuff
DescriptionJust a question... are zita-convolver and zita-resampler needed when building Mixbus? I'm building them here but I only realised this morning that Mixbus itself doesn't seem to distribute the zita modules.

Also... how do I re-open a closed thread? Originally I thought about adding this to an existing zita thread but I couldn't find a way to re-open it:-

https://tracker.ardour.org/view.php?id=7691#c23786
TagsNo tags attached.

Activities

x42

2020-05-30 12:36

administrator   ~0024307

We use patched version custom versions of those libs and they're part of Ardour's source tree.

External versions of those libraries are not no longer supported. This is because he resampler has new functionality that is not supported in the upstream lib (non interleaved audio data, and bypass), the convolver uses namespaced symbols (see 711f20a469e3).

johne53

2020-05-31 08:59

reporter   ~0024317

Thanks Robin - the gcc build links these libraries statically (whereas I've been building them as DLL's) and what confused me was that I couldn't find those DLL's after running the Mixbus installer.

It all makes sense now - thanks!

anonymous

2020-07-29 10:28

viewer   ~0024852

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-05-30 10:28 johne53 New Issue
2020-05-30 12:36 x42 Status new => feedback
2020-05-30 12:36 x42 Note Added: 0024307
2020-05-31 08:59 johne53 Note Added: 0024317
2020-05-31 08:59 johne53 Status feedback => new
2020-07-03 05:20 paul Assigned To => paul
2020-07-03 05:20 paul Status new => resolved
2020-07-03 05:20 paul Resolution open => fixed
2020-07-29 10:28 anonymous Note Added: 0024852
2020-07-29 10:28 anonymous Status resolved => closed