View Issue Details

IDCategoryLast Update
0008149bugs2020-07-25 13:14
ReporterelgounAssigned Topaul 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformLinuxOSDebianOS Version
Product Version6.0 
Fixed in Version 
Summary0008149: Layer display (Ovelaid/Stacked) doesn't apply to selected tracks anymore.
DescriptionLayer display (Ovelaid/Stacked) doesn't apply to all selected tracks anymore but the clicked one.

Looking at code this seems to be an intentional change, but it was handy to apply layering to all selected tracks.
Steps To Reproduce- Add 2 or more tracks
- Select 2 or more tracks
- Right click on a selected track header in editor and select "Layers=>Stacked"

Layering apply only to the clicked track.
TagsNo tags attached.

Activities

jeythekey

2020-06-27 01:57

reporter   ~0024513

I would like to second this request. Additionally, I would suggest that layering is shared between all regions in grouped tracks, independently of stacking. Especially, the layering in overlaid tracks should always follow the layering in stacked tracks of the same group. This is currently not the case, which does not make sense. It is, however, the case, if all tracks of that group are stacked.
Further (related?), changing the layer in a stacked track by moving a region up and down e.g. with the mouse sometimes destroys the group-locking of the regions in a group.

If layering is consistent between stacked and overlaid tracks in a group, having e.g. only the top track of a group stacked and the others overlaid would be very useful, as it would save vertical space, which is especially welcome when using stacking to organize multiple takes of the same piece/place (which I personally find a very useful strategy), especially in multi-channel-projects.

paul

2020-07-02 19:48

administrator   ~0024565

It is not possible to make layering consistent between tracks,. since their contents are not required to be the same.

Take management needs dramatic improval but this is not how we have been thinking about doing this.

paul

2020-07-02 20:52

administrator   ~0024567

Yes, the layering action change was deliberate. The per-track menu now only affects that track. What was missing was the menu item in the global Tracks menu. I've just added that, and believe that should resolve this issue.

jeythekey

2020-07-02 21:54

reporter   ~0024569

@paul: Could you imagine that layering can be made an optionally shared property of groups, similar to e.g. selection? I would find this super useful.

anonymous

2020-07-25 13:14

viewer   ~0024805

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-05-26 13:13 elgoun New Issue
2020-06-27 01:57 jeythekey Note Added: 0024513
2020-07-02 19:48 paul Note Added: 0024565
2020-07-02 20:52 paul Assigned To => paul
2020-07-02 20:52 paul Status new => resolved
2020-07-02 20:52 paul Resolution open => fixed
2020-07-02 20:52 paul Note Added: 0024567
2020-07-02 21:54 jeythekey Note Added: 0024569
2020-07-25 13:14 anonymous Note Added: 0024805
2020-07-25 13:14 anonymous Status resolved => closed