View Issue Details

IDCategoryLast Update
0008148bugs2020-07-23 21:48
ReporterderwokAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformLenovo Thinkpad T460sOSLinux UbuntuOS Version20.04
Product Version6.0 
Fixed in Version 
Summary0008148: MIDI note markers destroyed after mouse-over in percussive note mode
DescriptionUsing fresh 6.0.0 version.
In MIDI Note Mode: "Percussive", the blue mouse cursor line destroys the MIDI note markers while crossing the notes horizontally
Steps To Reproduce- Create MIDI track
- Add some notes
- Switch track display to: "Node Mode > Percussive"
- Have "Grab" mode tool active
- Move mouse horizontally over the MIDI notes, so the blue vertical mouse line goes back and forth across the note markers

Result: Note marker graphics are destroyed (see attached images: Before => After)
Additional InformationObservations:
- No MIDI notes are deleted. Its just a graphical/display issue
- Never seen this on Ardour 5.12
- This does only happen in Node Mode: percussive (NOT in MIDI Note Mode : sustained)
- This does NOT happen with "Draw Mode" tool. But "Grab mode" and "Range Mode" are destructive
- When mouse mode is changed, refresh happens
- Moving mouse right to left makes it worse than left to right

TagsMidi

Users sponsoring this issue
Sponsors List Total Sponsorship = US$ 5

2020-05-26 21:28: derwok (US$ 5)
Users sponsoring this issue (Total Sponsorship = US$ 5)

Activities

derwok

2020-05-24 21:42

reporter  

mhartzel

2020-05-25 07:28

reporter  

mhartzel

2020-05-25 07:28

reporter   ~0024265

I'm seeing similar note graphics corruption when the playhead travels over percussive notes. This seems to happen more on some specific zoom levels. When the playhead goes over the note its lower left corner is not redrawn again. In the attached picture Ardour is playing and you can see notes before and after the playhead.

OS: Manjaro XFCE
Kernel: 5.4.39-rt23-MANJARO 0000001 SMP PREEMPT_RT Sun May 10 19:40:07 UTC 2020 x86_64 GNU/Linux
Display Driver: Nvidia 430.64-12

x42

2020-07-09 00:12

administrator   ~0024654

Fixed in Ardour 6.2-2-gce8846d13f

anonymous

2020-07-23 21:48

viewer   ~0024804

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-05-24 21:42 derwok New Issue
2020-05-24 21:42 derwok Tag Attached: Midi
2020-05-24 21:42 derwok File Added: 2020-05-24_23-27 Ardour6 MIDI notes before.png
2020-05-24 21:42 derwok File Added: 2020-05-24_23-28 Ardour6 MIDI notes after.png
2020-05-25 07:28 mhartzel File Added: Ardour_6.0_Display_Corruption.png
2020-05-25 07:28 mhartzel Note Added: 0024265
2020-05-26 21:28 derwok Sponsorship Added derwok: US$ 5
2020-05-26 21:28 derwok Sponsorship Total 0 => 5
2020-07-03 05:34 paul Assigned To => paul
2020-07-09 00:12 x42 Assigned To paul => x42
2020-07-09 00:12 x42 Status new => resolved
2020-07-09 00:12 x42 Resolution open => fixed
2020-07-09 00:12 x42 Note Added: 0024654
2020-07-23 21:48 anonymous Note Added: 0024804
2020-07-23 21:48 anonymous Status resolved => closed