View Issue Details

IDCategoryLast Update
0008144bugs2020-07-23 19:07
Reportermantis_n1oifAssigned Topaul 
Reproducibilitysometimes 
Status closedResolutionno change required 
PlatformSome Other LinuxOSSome Other LinuxOS Versionunknown
Product Version6.0 
Fixed in Version 
Summary0008144: Ardour locks up on load
DescriptionArdour sometimes locks up when loading a session. Unfortunately this issue is intermittent and I don't have any further information about when it happens and when it doesn't. I took a screenshot of the failure.

Running in "--gdb" mode shows nothing interesting in the terminal window for debugging purposes.

fluidsynth: warning: No preset found on channel 0 [bank=128 prog=0]
fluidsynth: warning: No preset found on channel 0 [bank=0 prog=33]
fluidsynth: warning: No preset found on channel 0 [bank=0 prog=33]
fluidsynth: warning: No preset found on channel 9 [bank=128 prog=0]
fluidsynth: warning: No preset found on channel 0 [bank=128 prog=0]
fluidsynth: warning: No preset found on channel 9 [bank=128 prog=0]
fluidsynth: warning: No preset found on channel 0 [bank=128 prog=0]
fluidsynth: warning: No preset found on channel 9 [bank=128 prog=0]
fluidsynth: warning: No preset found on channel 0 [bank=128 prog=0]
fluidsynth: warning: No preset found on channel 9 [bank=128 prog=0]
locate took 9979 usecs for 9 tracks = 1109 per track
Reading player:Smashing_Pumpkins_-_Muzzle-t1-1-t2 took 5292 microseconds, final size = 5390
Reading player:Smashing_Pumpkins_-_Muzzle-t2-1-t3 took 3862 microseconds, final size = 5530
Reading player:Smashing_Pumpkins_-_Muzzle-t3-1-t4 took 14083 microseconds, final size = 13152
[New Thread 0x7fff89551700 (LWP 63366)]
Reading player:Smashing_Pumpkins_-_Muzzle-t4-1-t5 took 6573 microseconds, final size = 6621
Reading player:Muzzle1.0 -1-t1 took 1496 microseconds, final size = 2506
Reading player:Muzzle_montesavp-1-t1 took 2135 microseconds, final size = 2613
Reading bass took 260 microseconds, final size = 204
locate took 1268 usecs for 9 tracks = 141 per track
[Thread 0x7fffd59f7700 (LWP 63337) exited]
Steps To ReproduceLoad a session. The one causing issues for me has several midi tracks, one audio track with several plugins, 10+ automation lanes for those plugins and the playhead is set a few minutes into the song with two of the plugins being automated to "enable" at that point. Screenshot attached.

i can provide the session on request (copyrighted content).
Additional InformationUbuntu 20.04

Linux okcomputer 5.4.0-31-generic 0000035-Ubuntu SMP Thu May 7 20:20:34 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
TagsNo tags attached.

Relationships

related to 0008145 new Moving gxlivelooper in strip crashes Ardour 

Activities

mantis_n1oif

2020-05-24 19:04

reporter  

mantis_n1oif

2020-05-24 19:06

reporter   ~0024255

Launching the session in safe mode does allow me to actually get into the session and reset the playhead to the beginning. No lockup.

mantis_n1oif

2020-05-24 19:20

reporter   ~0024256

And then relaunching in non-safe mode (regular mode) with the playhead at the beginning (no automations enabled) does not lockup. Session seems back to normal.

And then (then) setting the playhead to (approximately) the same location where it was locking up and restarting Ardour does NOT cause a lockup.

So it's an intermittent thing I can't immediately reproduce. Sorry.

anonymous

2020-07-23 19:07

viewer   ~0024798

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-05-24 19:04 mantis_n1oif New Issue
2020-05-24 19:04 mantis_n1oif File Added: Screenshot from 2020-05-24 15-02-44.png
2020-05-24 19:06 mantis_n1oif Note Added: 0024255
2020-05-24 19:20 mantis_n1oif Note Added: 0024256
2020-05-24 19:59 x42 Relationship added related to 0008145
2020-05-27 17:38 paul Assigned To => paul
2020-05-27 17:38 paul Status new => resolved
2020-05-27 17:38 paul Resolution open => no change required
2020-07-23 19:07 anonymous Note Added: 0024798
2020-07-23 19:07 anonymous Status resolved => closed