View Issue Details

IDCategoryLast Update
0008119bugs2020-05-24 21:14
ReporterjoboschettiAssigned Topaul 
Reproducibilityalways 
Status resolvedResolutionunable to reproduce 
PlatformLinuxOSOpensuseOS Version15.1 15.2
Product Version6.0-pre1 
Fixed in Version 
Summary0008119: Crash on delete tracks
Descriptiongtkmm:ERROR:treestore.cc:52:Gtk::TreeModel::iterator Gtk::TreeStore::erase(const iterator&): assertion failed: (iter.get_gobject_if_not_end() != 0)
Bail out! gtkmm:ERROR:treestore.cc:52:Gtk::TreeModel::iterator Gtk::TreeStore::erase(const iterator&): assertion failed: (iter.get_gobject_if_not_end() != 0)
Steps To ReproduceDelete track (or cut)
Additional Informationi have tested RC official, and latest git. bit not luck. Compiled on every configuration (internal, external libs and other tweack). same issue on every build.

I need version 6 for midi record over the track, but unusable
TagsNo tags attached.

Relationships

has duplicate 0008124 new Crash on deleting track (gtkmm:ERROR) 

Activities

joboschetti

2020-05-18 13:00

reporter   ~0024184

bug is applicable on every version and build of Ardour6 (mixbus ardour 6), precompiled, selfcompiled, and build service compiled. Bug is on execution

joboschetti

2020-05-18 16:31

reporter   ~0024188

113733947 DEBUG::Keyboard: Snoop widget 0x558447b714b0 name: [gtkmm__GtkWindow] key 65535 [Delete] type 8 state 16 [+MOD2] magic 0
113734117 DEBUG::Keyboard: snooper returns 0
113734329 DEBUG::Accelerators: main window key event, bindings = 0x558448519700, global = 0x558447b15ad0
113734565 DEBUG::Accelerators: Win = 0x558447b714b0 [title = ard6test - Ardour] focus = EditorMainCanvas (no) Key event: code = 65535 [Delete] state = +MOD2 special handling ? 0 magic widget focus ? 0 focus widget 0x55844c1e8300 named EditorMainCanvas mods ? no
113734591 DEBUG::Accelerators: activate, then propagate
113734663 DEBUG::Accelerators: using widget bindings MIDI @ 0x5584486b1d10 for this event
113734800 DEBUG::Bindings: binding for Key 65535 (Delete) state 0 : Notes/alt-delete - insensitive, skipped
113734876 DEBUG::Accelerators: using widget bindings Editor @ 0x558448519700 for this event
113734939 DEBUG::Bindings: binding for Key 65535 (Delete) state 0 : Editor/editor-delete
113735452 PBD::DEBUG::UndoHistory: 3045: Begin Reversible Command, new transaction: elimina oggetti
113736945 PBD::DEBUG::AbstractUI: gui/ArdourGUI direct dispatch of call slot via functor @ 0x7fff3288f1a0, invalidation 0x55844a504c00
113737034 PBD::DEBUG::AbstractUI: gui/ArdourGUI direct dispatch of call slot via functor @ 0x7fff3288e990, invalidation 0
113737082 PBD::DEBUG::AbstractUI: gui/ArdourGUI direct dispatch of call slot via functor @ 0x7fff3288e990, invalidation 0
113737122 PBD::DEBUG::AbstractUI: gui/ArdourGUI direct dispatch of call slot via functor @ 0x7fff3288e990, invalidation 0
113737160 PBD::DEBUG::AbstractUI: gui/ArdourGUI direct dispatch of call slot via functor @ 0x7fff3288e990, invalidation 0x5584479b8570
113737865 PBD::DEBUG::AbstractUI: gui/ArdourGUI direct dispatch of call slot via functor @ 0x7fff3288e820, invalidation 0
113737918 PBD::DEBUG::AbstractUI: gui/ArdourGUI direct dispatch of call slot via functor @ 0x7fff3288e820, invalidation 0
113738121 PBD::DEBUG::AbstractUI: gui/ArdourGUI direct dispatch of call slot via functor @ 0x7fff3288e820, invalidation 0
113738183 PBD::DEBUG::AbstractUI: gui/ArdourGUI direct dispatch of call slot via functor @ 0x7fff3288e820, invalidation 0
113738537 PBD::DEBUG::EventLoop: ArdourGUI: invalidating request from 0x558447b15970 (gui) @ 0x55844abb7400
113738593 PBD::DEBUG::EventLoop: ArdourGUI: invalidating request from 0x558447b15970 (gui) @ 0x55844eecac00
113738628 PBD::DEBUG::EventLoop: ArdourGUI: invalidating request from 0x558447b15970 (gui) @ 0x55844d0af530
113740158 PBD::DEBUG::CanvasEnterLeave: (156, 278) covers 9 items
        Item Root/ROOT ignore events ? 0 vis ? 1
        Item ScrollGroup/canvas h scroll ignore events ? 0 vis ? 1
        Item Container/time line group ignore events ? 0 vis ? 1
        Item ScrollGroup/canvas hv scroll ignore events ? 0 vis ? 1
        Item Container/Canvas TrackViews ignore events ? 0 vis ? 1
        Item Container/main for Audio 1 ignore events ? 0 vis ? 1
        Item Container/SV canvas group Audio 1 ignore events ? 0 vis ? 1
        Item Rectangle/SV canvas rectangle Audio 1 ignore events ? 0 vis ? 1
        Item ScrollGroup/canvas cursor scroll ignore events ? 0 vis ? 1
113740944 PBD::DEBUG::CanvasEnterLeave: after filtering insensitive + containers, we have 1 items
113741010 PBD::DEBUG::CanvasEnterLeave: enter Container/SV canvas group Audio 1
113741044 PBD::DEBUG::CanvasEnterLeave: enter Container/main for Audio 1
113741074 PBD::DEBUG::CanvasEnterLeave: enter Container/Canvas TrackViews
113741104 PBD::DEBUG::CanvasEnterLeave: enter ScrollGroup/canvas hv scroll
113741133 PBD::DEBUG::CanvasEnterLeave: enter Root/ROOT
113741162 PBD::DEBUG::CanvasEnterLeave: ENTER Rectangle/SV canvas rectangle Audio 1
113741271 PBD::DEBUG::CanvasEnterLeave: CURRENT ITEM Rectangle/SV canvas rectangle Audio 1
113741868 PBD::DEBUG::EventLoop: ArdourGUI: invalidating request from 0x558447b15970 (gui) @ 0x5584482f8940
113742184 PBD::DEBUG::AbstractUI: gui/ArdourGUI direct dispatch of call slot via functor @ 0x7fff3288f0e0, invalidation 0x55844d5d3170
113742275 PBD::DEBUG::AbstractUI: gui/ArdourGUI direct dispatch of call slot via functor @ 0x7fff3288f0e0, invalidation 0
**
gtkmm:ERROR:treestore.cc:49:Gtk::TreeModel::iterator Gtk::TreeStore::erase(const iterator&): assertion failed: (iter.get_gobject_if_not_end() != 0)
Annullato (core dump creato)

paul

2020-05-18 20:10

administrator   ~0024191

Last edited: 2020-05-18 20:14

View 2 revisions

could you please specify the steps you took to delete the track

i cannot reproduce this crash, and indeed, cannot delete a track using a key.

joboschetti

2020-05-18 20:27

reporter   ~0024193

Thanks for the reply. everything works, but when you delete a track it crashes, selecting it and pressing delete, or even right mouse button, cut (I tried to do workaround).

the bug comes out after all the updates of the distribution, as soon as installed, I only have a clean distribution. on 15.1 it is rare, on 15.2 it always happens without any solution. everything works, only ardor 6, and mixbus 6, in all variations, have this bug. it does not apply to 5 and any other software

paul

2020-05-18 21:14

administrator   ~0024194

Sorry, but this still isn't an explanation that I can follow.

Can you provide very precise steps that you take (every mouse button, every keyboard key) in order to cause this.

joboschetti

2020-05-19 01:02

reporter   ~0024195

Open project, (new or older, not inportant), mouse left click on existent track (record one if not present), for select, canc/del key on keyboard.

Mouse Right click on the track,and "cut" generate same error.

No mode for deleting track (midi, audio, inported or taked)

paul

2020-05-19 01:20

administrator   ~0024196

1) what type of track, audio or MIDI?
2) the keyboard shortcut in your debug output does not and cannot delete tracks, so I am not clear what it is that you are deleting/cutting ....

joboschetti

2020-05-19 01:29

reporter   ~0024197

Specifically in this output, audio file, and used a "del" only key on keyboard. Tomorrow if it is useful to you, I can try other cancellation actions that you tell me, and I put the debug (today's specific output refers to the "del" key) but I can put the cutting debug here so as to give you extra elements

joboschetti

2020-05-19 01:32

reporter   ~0024198

Ps on ardour5 same action with keyboard, "del" key, correspond to delete track and not crash

joboschetti

2020-05-19 01:33

reporter   ~0024199

For track, i refer to tracks or portion of tracks, on the timeline

paul

2020-05-19 02:58

administrator   ~0024200

OK, "tracks or portions of tracks" is a reflects some important terminology problems.

"portions of tracks" are called "regions" in ardour (and protools; some other DAWS refer to them as "clips")

Deleting a track means deleting the actual track, not contents of the track ("portions of a track"). There is no way to do this with a keyboard shortcut.

So, you are describing deleting a region (which may be the only region in the track) ? And then having problems as a result (and immediately after) ?

joboschetti

2020-05-19 11:13

reporter   ~0024203

Yep, Sorry for incorrect terminology, i refer to region (any region, midi audio importer or taked)

paul

2020-05-19 18:50

administrator   ~0024206

I cannot replicate this error with the instructions given.

x42

2020-05-19 20:59

administrator   ~0024210

Could you get a backtrace from this crash?

Get debug-build (https://nightly.ardour.org/). Then launch Ardour from a terminal window:

Ardour6 --gdb
[...]
(gdb) run <press enter>

Now make ardour crash, that returns gdb's prompt, there:

(gdb)  thread apply all bt


and press enter a few times (output will be several pages long) and attach the backtrace here.
-- see also https://ardour.org/debugging_ardour

x42

2020-05-19 21:01

administrator   ~0024211

There are various Ardour and MIxbus users who don't have this issue. So perhaps there's something "special" about your system.. Maybe translations?
or maybe some preferences, custom key-binding issue? Moving ~/.config/ardour6 away and starting a new might help, have you tried that?

joboschetti

2020-05-20 17:03

reporter   ~0024214

hi, yes I did all the tests. The problem seems to be related to Leap 15.2, I suspect both with the new desktop plasma, since by downgrading to 15.1 with updated plasma, it kept the problem. Clean installation of 15.1 has fixed. I had tried format several times, but I had never tried without plasma updated on 15.1. I would still pay attention to any problems with the new versions of desktop plasma.

Issue History

Date Modified Username Field Change
2020-05-16 20:36 joboschetti New Issue
2020-05-18 13:00 joboschetti Note Added: 0024184
2020-05-18 16:31 joboschetti Note Added: 0024188
2020-05-18 20:08 x42 Relationship added has duplicate 0008124
2020-05-18 20:10 paul Note Added: 0024191
2020-05-18 20:14 paul Note Edited: 0024191 View Revisions
2020-05-18 20:27 joboschetti Note Added: 0024193
2020-05-18 21:14 paul Note Added: 0024194
2020-05-19 01:02 joboschetti Note Added: 0024195
2020-05-19 01:20 paul Note Added: 0024196
2020-05-19 01:29 joboschetti Note Added: 0024197
2020-05-19 01:32 joboschetti Note Added: 0024198
2020-05-19 01:33 joboschetti Note Added: 0024199
2020-05-19 02:58 paul Note Added: 0024200
2020-05-19 11:13 joboschetti Note Added: 0024203
2020-05-19 18:50 paul Note Added: 0024206
2020-05-19 20:59 x42 Note Added: 0024210
2020-05-19 21:01 x42 Note Added: 0024211
2020-05-20 17:03 joboschetti Note Added: 0024214
2020-05-24 21:14 paul Assigned To => paul
2020-05-24 21:14 paul Status new => resolved
2020-05-24 21:14 paul Resolution open => unable to reproduce