View Issue Details

IDCategoryLast Update
0008116bugs2020-05-15 20:52
ReporterAlexanderAssigned Topaul 
Reproducibilityalways 
Status resolvedResolutionwon't fix 
Platformx86-amd64OSDebianOS VersionTesting Bullseye
Product Version6.0-pre1 
Fixed in Version 
Summary0008116: Ardour refuses to load midi file recorded by GrandOrgue
DescriptionI made a midi recording using GrandOrgue and tried to import it into Ardour (c79b56d0692e92d67af6cfa36233e7709339ce68), it says "One or more of the selected files
cannot be used by Ardour". I tried it with a long recording and also with a very short one where I only play a C once. GrandOrgue somehow records the organ stops used by the organist, perhaps that causes trouble. I also tried disabling all stops, no difference.
Steps To Reproduce1. Open new session
2. Try to import attached midi file
TagsMidi

Activities

Alexander

2020-05-15 19:49

reporter  

ardour-test.mid (4,150 bytes)

paul

2020-05-15 20:47

administrator   ~0024157

This MIDI files uses SMPTE/timecode timestamps, not musical ticks. The SMF library we use does not support this internally, and Ardour would not want to use it even if the library could use it.

There is likely an option in the application that generated it to control what sort of time to use when writing the file.

Issue History

Date Modified Username Field Change
2020-05-15 19:49 Alexander New Issue
2020-05-15 19:49 Alexander Tag Attached: Midi
2020-05-15 19:49 Alexander File Added: ardour-test.mid
2020-05-15 20:47 paul Note Added: 0024157
2020-05-15 20:52 paul Assigned To => paul
2020-05-15 20:52 paul Status new => resolved
2020-05-15 20:52 paul Resolution open => won't fix