View Issue Details

IDCategoryLast Update
0008111bugs2020-05-15 23:29
ReporterahellquistAssigned Topaul 
Reproducibilityalways 
Status resolvedResolutionfixed 
PlatformSome Other LinuxOSSome Other LinuxOS Versionunknown
Product Version6.0-pre1 
Fixed in Version 
Summary0008111: Ardour 6.0.rc1.298 Huge spike when looping audio tracks +40dB
DescriptionLooping audio spikes at loop cycle. Huge blast in output.
Ubuntu studio 20.04
TagsNo tags attached.

Relationships

related to 0008001 resolvedpaul Playhead and audio get out of sync when loop range is changed whilst playing 

Activities

ahellquist

2020-05-14 10:33

reporter  

MMP404

2020-05-14 14:47

reporter   ~0024147

I get the same spike when looping an imported audio region in rc1.298. This does not occur in rc1.251.

paul

2020-05-14 21:27

administrator   ~0024148

I need a precise recipe in order to work on this. Both myself and other users have not noticed this when testing other looping-related fixes.

paul

2020-05-14 23:06

administrator   ~0024149

Please also report on Edit > Preferences > Transport > Loop fade settings.

ahellquist

2020-05-14 23:28

reporter   ~0024150

I have a simple session that I have been using for a while containing a few tracks with drum loops as well as pianoteq and a few U-he synths. I use the session for practice and today I just noticed the 40dB Spike and all the red overload indicators. Maybe this is related to all the things been done to loop off by one stuff and is purely caused by my session not being compatible with those changes?

How can I help since there is no clear recepie but apparently I am not alone.

paul

2020-05-15 02:03

administrator   ~0024151

Just attach the archive (Session > Archive) of the session and I can test it here.

ahellquist

2020-05-15 19:01

reporter   ~0024153

My 1.2 MB session file seems to be too big for mantis..

It is below 2MB and should work.. why ?

<html> <head><title>413 Request Entity Too Large</title></head> <body bgcolor="white"> <center><h1>413 Request Entity Too Large</h1></center> <hr><center>nginx</center> </body> </html>
Remove file

paul

2020-05-15 19:12

administrator   ~0024154

Email it to me via paul@linuxaudiosystems.com

ahellquist

2020-05-15 19:44

reporter   ~0024156

session file sent by email

ahellquist

2020-05-15 21:10

reporter   ~0024159

I think I have a clue to this problem.
i did listen to this session again after sending it to paul and the problem did not manifest during a few loops..

By mistake I sometimes left ardour nighly looping a few hours (this is the demo version that goes silent) and I think the odd behavior i related to the silence part. When left in loop for a long time, Ardour can make subtle noises when looping (after it has gone "silent") and that noise is slowly building up after some time.

When I fiddle with nightly builds I tend to snooze the silencer many many times and I suspect that is not handled correctly by Ardour and might give spikes down the road.. Maybe this is true for MMP404 too ?

krischan941

2020-05-15 22:43

reporter   ~0024160

I can reproduce this issue. The 40db peak happens when the loop begins at 00:00:00. It doesn't need to contain any audio.

krischan941

2020-05-15 22:43

reporter   ~0024161

Ardour 6.0.rc1.298

krischan941

2020-05-15 22:46

reporter   ~0024162

And it only happens with "Corss-Fade loop end and start" for me.

ahellquist

2020-05-15 22:51

reporter   ~0024163

@krischan941
great, I was beginning to question myself since after sending my session to Paul, I did not experience the issue..

paul

2020-05-15 23:29

administrator   ~0024167

@krischan941: thanks!

fixed as of d812c77362

Issue History

Date Modified Username Field Change
2020-05-14 10:33 ahellquist New Issue
2020-05-14 10:33 ahellquist File Added: Screenshot_2020-05-14_12-32-15.png
2020-05-14 12:12 x42 Relationship added related to 0008001
2020-05-14 14:47 MMP404 Note Added: 0024147
2020-05-14 21:27 paul Note Added: 0024148
2020-05-14 23:06 paul Assigned To => paul
2020-05-14 23:06 paul Note Added: 0024149
2020-05-14 23:28 ahellquist Note Added: 0024150
2020-05-15 02:03 paul Note Added: 0024151
2020-05-15 19:01 ahellquist Note Added: 0024153
2020-05-15 19:12 paul Note Added: 0024154
2020-05-15 19:44 ahellquist Note Added: 0024156
2020-05-15 21:10 ahellquist Note Added: 0024159
2020-05-15 22:43 krischan941 Note Added: 0024160
2020-05-15 22:43 krischan941 Note Added: 0024161
2020-05-15 22:46 krischan941 Note Added: 0024162
2020-05-15 22:51 ahellquist Note Added: 0024163
2020-05-15 23:29 paul Status new => resolved
2020-05-15 23:29 paul Resolution open => fixed
2020-05-15 23:29 paul Note Added: 0024167