View Issue Details

IDCategoryLast Update
0008076bugs2020-07-01 17:15
ReporterrozeaAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformSome Other LinuxOSSome Other LinuxOS Versionunknown
Product Version6.0-pre1 
Fixed in Version 
Summary0008076: Ardour 6 doesn't launch in the Non-session-manager
DescriptionUsing Ardour 6 latest git today. Default Non-session-manager GUI. (Debian testing)

Messages in terminal of NSM:
 Got announce from Ardour
[nsmd] Client was expected.
[nsmd] Process has pid: 23199
[nsmd] The client "Ardour" at "osc.udp://127.0.0.1:18353/" informs us it's ready to receive commands.
[nsmd] Client "Ardour" replied with: OK in 0.201000ms
Ardour: [ERROR]: NSM: no session created
[nsmd] Client Ardour died unexpectedly.

Messages in NSM GUI:

19:02:49 Launching ardour6
19:02:50 Got announce from Ardour
19:02:51 Client Ardour died unexpectedly.

Steps To ReproduceStart JACK
non-session-manager
New (session)
add client to session
ardour6
Additional Informationnone
TagsNSM

Activities

rozea

2020-05-02 18:23

reporter   ~0024038

Maybe it fails when trying to make a dedicated folder for internal ardour data? When I add non-timeline for instance, there is a folder made for non-timeline in the NSM session folder

~/NSM Sessions/ardour6$ cat session.nsm
JACKPatch:jackpatch:nENOT
Ardour:ardour6:nIMHK
Non-Timeline:non-timeline:nWUGO

:~/NSM Sessions/ardour6$ ls
JACKPatch.nENOT.jackpatch Non-Timeline.nWUGO session.nsm

x42

2020-05-21 00:06

administrator   ~0024215

This should be fixed since 6.0-rc2-6-g5d0867ec10
Please test

rozea

2020-05-21 11:46

reporter   ~0024217

Ardour6 does launch in NSM now. Thanks!

anonymous

2020-07-01 17:15

viewer   ~0024555

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-05-02 17:14 rozea New Issue
2020-05-02 17:14 rozea Tag Attached: NSM
2020-05-02 18:23 rozea Note Added: 0024038
2020-05-21 00:06 x42 Assigned To => x42
2020-05-21 00:06 x42 Status new => feedback
2020-05-21 00:06 x42 Note Added: 0024215
2020-05-21 11:46 rozea Note Added: 0024217
2020-05-21 11:46 rozea Status feedback => assigned
2020-05-21 14:18 x42 Status assigned => resolved
2020-05-21 14:18 x42 Resolution open => fixed
2020-07-01 17:15 anonymous Note Added: 0024555
2020-07-01 17:15 anonymous Status resolved => closed