View Issue Details

IDCategoryLast Update
0008070features2020-06-29 12:14
ReporterdhealeyAssigned Topaul 
ReproducibilityN/A 
Status closedResolutionwon't fix 
Product Version 
Fixed in Version 
Summary0008070: Add automation lane for plugin on/off button
DescriptionI know that plugins should implement their own bypass button and expose it as an automatable parameter, but many don't, including some that come with Ardour. This wouldn't be an issue if the plugins had other automatable parameters that disabled their ability to affect the incoming audio, but again not all do.

For example AM Pitchshifter by Steve Harris has an automatable parameter that changes the pitch of incoming audio. When set to 1.00 it should have no effect, but it does, it reduces the volume of the audio. I can turn it off manually by clicking the button but without automation I either have to have it off for the whole track, on with it affecting the audio even when I don't need it, or I have to split my work between multiple tracks which is not so easy with a complicated fx chain, routing, and automation. This is just one example, I'm sure there are many other plugins with similar issues.

Yes I understand it's an issue with the plugin, but rather than every user who encounters the issue having to track down each plugin developer and hoping they'll implement a bypass button it could be universally solved by adding an on/off button automation lane to Ardour - with the necessary hacky crossfade technique I've seen mentioned, that might be technically unappealing but does the job satisfactorily for end users.
TagsNo tags attached.

Activities

x42

2020-04-30 13:51

administrator   ~0024011

That is not very likely going to happen. I'm sorry.

It would it add additional overhead (a cross-fade gain stage) for every plugin. And that will also be wrong on the vast majority of cases. Even in cases where cross-fade would be the right approach, the required cross-fade duration is unknown.

Plugin-specs (VST and LV2) allow plugins to expose a bypass/enable control, Ardour supports that.

If you really must, you can use a dedicated cross-fade plugin and wrap it around the plugin.

dhealey

2020-04-30 23:07

reporter   ~0024016

:( Fair enough, on another note I was able to add a bypass button myself to AM Pitchshifter, the joys of free software :)

anonymous

2020-06-29 12:14

viewer   ~0024524

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-04-30 12:13 dhealey New Issue
2020-04-30 13:51 x42 Note Added: 0024011
2020-04-30 23:07 dhealey Note Added: 0024016
2020-05-01 04:03 paul Assigned To => paul
2020-05-01 04:03 paul Status new => resolved
2020-05-01 04:03 paul Resolution open => won't fix
2020-06-29 12:14 anonymous Note Added: 0024524
2020-06-29 12:14 anonymous Status resolved => closed