View Issue Details

IDCategoryLast Update
0008030bugs2020-07-03 05:37
Reporterkrischan941Assigned Topaul 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformOSUbuntu OS Version19.10
Product Version6.0-pre1 
Fixed in Version 
Summary0008030: visual artifacts
DescriptionSee short video: https://www.dropbox.com/s/zyzpt7ftxbtoh4o/visual%20artifacts.mp4?dl=0
Using Ardour 6.0.rc1.2 on Ubuntu 19.10.
1. The Shuttle Speed Control is very tiny and therefore not realy usable (1 - 12 sec)
2. Left click a region and press 'z' to zoom in. After that press several times 'z' to zoom out. Then scroll down to the last track. It gets visually multiplied. (video 15 - 35 sec)
TagsNo tags attached.

Relationships

has duplicate 0008061 new "Zoom to Selection" creates a phantom clone of the last track 

Activities

paul

2020-04-28 19:37

administrator   ~0023992

The shuttle speed control isn't intended by be particularly fine resolution. You may want to shift the units to semitones. It is also designed to be most usable with a mouse scroll wheel (and in "wheel mode" even more so).

Even so the visual appearance here is odd. The default position for the "handle" should be in the middle, not on the left.

krischan941

2020-04-29 19:36

reporter   ~0023997

I had the intuition to click and drag the controller and therefore my statement. But yes, it is perfect usable with a mouse scroll wheel.

paul

2020-04-29 19:47

administrator   ~0023998

Last edited: 2020-04-29 19:48

View 2 revisions

Do you have any idea how the slide/handle itself ends up on the left side?

krischan941

2020-04-29 20:59

reporter   ~0023999

No idea. Out of interest I compiled Ardour myself, meanwhile on Ubuntu 20.04. There it looks good.

paul

2020-04-29 22:23

administrator   ~0024002

Where did you get it from before compiling it yourself?

krischan941

2020-04-30 09:01

reporter   ~0024008

From nightly.ardour.org (now current v6.0-rc1-146, 64bit, gcc5)
There are another few things which look different. The plus button for adding tracks in the mixer has another color, the "add tracks dialogue" has some more entries and the menu bar is slightly bigger in the self build version.

nightly_v6.0_rc1_146.png (186,195 bytes)
nightly_v6.0_rc1_146.png (186,195 bytes)
self_build.png (191,729 bytes)
self_build.png (191,729 bytes)

paul

2020-04-30 13:15

administrator   ~0024009

The obvious difference there is translation. That shoudn't have the effects noted, however. Might be a useful clue to help track it down ....

paul

2020-04-30 13:18

administrator   ~0024010

What waf configure options do you use with your self-build ?

krischan941

2020-04-30 16:52

reporter   ~0024013

I used the commands written by x42 on https://discourse.ardour.org/t/i-want-to-be-part-of-it/103018/2 .
So these configure options:
./waf configure --strict --cxx11 --with-backends=jack,alsa,pulseaudio,dummy

paul

2020-04-30 19:07

administrator   ~0024014

These problems appear to have been caused by errors in the german translation. I have fixed an entire category of error for the de_DE.utf8 translation which I think fixes these errors.

krischan941

2020-05-01 15:51

reporter   ~0024021

Great, the slide now (nightly Ardour 6.0.rc1.157) looks good. The rest is the same as before.

paul

2020-05-01 16:21

administrator   ~0024022

With the self build version, what steps do you take after ./waf configure ?

Could you attach a screenshot showing the mixer button color difference? Thanks

krischan941

2020-05-01 17:46

reporter   ~0024023

"With the self build version, what steps do you take after ./waf configure ?"
./waf

Differences are marked in white.

mixer button etc.png (334,220 bytes)

krischan941

2020-05-02 11:23

reporter   ~0024034

Here are my complete build steps:

sudo apt-get build-dep ardour
git clone https://github.com/Ardour/ardour.git
cd ardour
./waf configure --strict --cxx11 --with-backends=jack,alsa,pulseaudio,dummy
./waf
cd gtk2_ardour
./ardev

x42

2020-05-04 21:40

administrator   ~0024063

The differences are translations, those are not available when running from source-tree (you'll have to package or install it).
The self-build also shows additional example Track-templates (share/scripts/_*) that are not bundled.

The "+" button style is because you use a different gtk theme and different gtk-version when you compile Ardour.
There are also a couple of other subtle differences when you use default debian/ubuntu's gtk.

krischan941

2020-05-06 10:15

reporter   ~0024082

Ah ok. Thank you for your explanation.

Thank you very much paul for fixing the first bug in my description.

Should I close this bug report? The second one is reported by another user in 0008061. Maybe it wasn't a good idea to couple these two bugs in one report..

anonymous

2020-07-03 05:37

viewer   ~0024589

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-04-20 09:16 krischan941 New Issue
2020-04-27 12:35 x42 Relationship added has duplicate 0008061
2020-04-28 19:37 paul Note Added: 0023992
2020-04-29 19:36 krischan941 Note Added: 0023997
2020-04-29 19:47 paul Note Added: 0023998
2020-04-29 19:48 paul Note Edited: 0023998 View Revisions
2020-04-29 20:59 krischan941 Note Added: 0023999
2020-04-29 22:23 paul Note Added: 0024002
2020-04-30 09:01 krischan941 File Added: nightly_v6.0_rc1_146.png
2020-04-30 09:01 krischan941 File Added: self_build.png
2020-04-30 09:01 krischan941 Note Added: 0024008
2020-04-30 13:15 paul Note Added: 0024009
2020-04-30 13:18 paul Note Added: 0024010
2020-04-30 16:52 krischan941 Note Added: 0024013
2020-04-30 19:07 paul Note Added: 0024014
2020-05-01 15:51 krischan941 File Added: Bildschirmfoto von 2020-05-01 17-45-17.png
2020-05-01 15:51 krischan941 Note Added: 0024021
2020-05-01 16:21 paul Note Added: 0024022
2020-05-01 17:46 krischan941 File Added: mixer button etc.png
2020-05-01 17:46 krischan941 Note Added: 0024023
2020-05-02 11:23 krischan941 Note Added: 0024034
2020-05-04 21:40 x42 Note Added: 0024063
2020-05-06 10:15 krischan941 Note Added: 0024082
2020-07-03 05:37 paul Assigned To => paul
2020-07-03 05:37 paul Status new => resolved
2020-07-03 05:37 paul Resolution open => fixed
2020-07-03 05:37 anonymous Note Added: 0024589
2020-07-03 05:37 anonymous Status resolved => closed