View Issue Details

IDCategoryLast Update
0007942bugs2020-05-26 08:37
ReportersciuriusAssigned Topaul 
Reproducibilityalways 
Status closedResolutionfixed 
Product Version6.0-pre1 
Fixed in Version 
Summary0007942: Disallow placement of a CD marker at location zero
DescriptionArdour allows placement of a CD marker at location zero, e.g. create a CD marker and shift it to leftmost. This is not allowed according to the Red Book.
Steps To ReproduceCreate a new project.
Import some audio.
Create a CD marker.
Shift the marker to leftmost (0:00:00:00).

A message is added to the log window: [ERROR]: You cannot put a CD marker at the start of the session.
This will most likely go unnoticed.
Additional InformationSince the marker and all its associated information will get lost upon save/restore, I think it is better to issue a pop-up error dialog.

See also issue https://tracker.ardour.org/view.php?id=7936
TagsNo tags attached.

Relationships

related to 0007936 new CD marker gets lost when at zero 

Activities

paul

2020-03-28 16:59

administrator   ~0021075

fixed in 144bfb6278]

anonymous

2020-05-26 08:37

viewer   ~0024269

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-03-27 08:36 sciurius New Issue
2020-03-28 02:28 x42 Relationship added related to 0007936
2020-03-28 16:59 paul Assigned To => paul
2020-03-28 16:59 paul Status new => resolved
2020-03-28 16:59 paul Resolution open => fixed
2020-03-28 16:59 paul Note Added: 0021075
2020-05-26 08:37 anonymous Note Added: 0024269
2020-05-26 08:37 anonymous Status resolved => closed