View Issue Details

IDCategoryLast Update
0007900bugs2020-02-19 14:32
Reportermantis_n1oifAssigned Tox42 
Reproducibilityalways 
Status resolvedResolutionfixed 
PlatformSome Other LinuxOSSome Other LinuxOS Versionunknown
Product Version6.0-pre0 
Fixed in Version 
Summary0007900: Deleting .mid files from session directory tree causes segfault on next load
DescriptionDeleting .mid files from session directory tree causes segfault on next load
Steps To Reproducein the session root of an ardour session with a midi track, delete *.mid from the directory tree.
Try to load session in ardour.

Seg fault.

Additional InformationArdour6.0.pre0.3409 (built using 6.0-pre0-3409-gd7fed7c52e and GCC version 9.2.1 20191008)

Ubuntu 19.10
TagsNo tags attached.

Activities

x42

2020-02-15 18:35

administrator   ~0020962

What do you expect in this case?

Should Ardour create empty MIDI regions in place (like silent audio-regions are created for missing audio)?

For missing Audio files, Ardour shows a dialog and asks the user to locate the files. Audio is non-destructive and Ardour can reference external-files (which may be moved).
MIDI however is always in Ardour's session-folder, since it's edited destructively no external files can be referenced. If a file is missing, there's almost no point in asking the user about it.

I think the way forward is to re-create the missing files as empty .mid, and retain the regions. Then show an error dialog (not just a log message):
"MIDI files were found missing: ... Ardour has replaced them file empty/silent MIDI data. If this is unexpected and you have backup files, you can manually copy them over, and re-start Ardour"

mantis_n1oif

2020-02-15 18:41

reporter   ~0020963

You can use your best judgement on that. For my use case, I'd be ok with no regions, empty regions or even deleted tracks (but this seems extreme). All I care about is that the session is loadable (and loadable without having to click an "ok" through an error message), even when expected .mid files are gone.

paul

2020-02-16 18:51

administrator   ~0020964

There will have to be an OK at some point. We're never going to sanction "oh, just ignore all missing files today, tomorrow and forever".

mantis_n1oif

2020-02-17 00:02

reporter   ~0020965

Yeah I get that. I'm mostly concerned about the lua version.

x42

2020-02-18 00:31

administrator   ~0020966

Fixed in 6.0-pre0-3417-g60a2406056 -- the warning (Missing Source Files) is shown in the GUI only. Headless/Lua will silently replace the MIDI with silence

Issue History

Date Modified Username Field Change
2020-02-13 19:22 mantis_n1oif New Issue
2020-02-15 18:35 x42 Note Added: 0020962
2020-02-15 18:41 mantis_n1oif Note Added: 0020963
2020-02-16 18:51 paul Note Added: 0020964
2020-02-17 00:02 mantis_n1oif Note Added: 0020965
2020-02-18 00:31 x42 Note Added: 0020966
2020-02-19 14:32 x42 Assigned To => x42
2020-02-19 14:32 x42 Status new => resolved
2020-02-19 14:32 x42 Resolution open => fixed