View Issue Details

IDCategoryLast Update
0007873bugs2020-01-10 18:00
ReportersciuriusAssigned Tox42 
Reproducibilityalways 
Status resolvedResolutionfixed 
Platformx86_64OSFedoraOS Version29
Product Version5.12 
Fixed in Version 
Summary0007873: Track insert time does not affect all tracks
DescriptionTrack > Insert time requires one track to be selected, but the dialog has a checkbox "apply to all tracks in the playlist".
When the selected action for intersected regions is "be split", the operation only affects the selected track, not all tracks, even though this checkbox is checked.

See attachments: screendump before, and after.
TagsNo tags attached.

Activities

sciurius

2020-01-10 09:14

reporter  

scrot20200110100646.png (69,197 bytes)
scrot20200110100646.png (69,197 bytes)
scrot20200110100706.png (40,077 bytes)
scrot20200110100706.png (40,077 bytes)

x42

2020-01-10 14:29

administrator   ~0020908

The label is "Apply to all the track's playlists".
In other words: "Apply to all playlists of the selected Track(s), not just the currently active playlist of the selected Track(s)".

A single track can have multiple playlists (check with the "P" button the track-header): https://manual.ardour.org/working-with-playlists/understanding-playlists/

sciurius

2020-01-10 17:52

reporter   ~0020909

Thanks!

x42

2020-01-10 18:00

administrator   ~0020910

I've clarified the message in the dialog.

Since Ardour 6.0-pre0-3193-ga883afbd64 the checkbox options now reads "Apply to all playlists of the selected track(s)"

Issue History

Date Modified Username Field Change
2020-01-10 09:14 sciurius New Issue
2020-01-10 09:14 sciurius File Added: scrot20200110100646.png
2020-01-10 09:14 sciurius File Added: scrot20200110100706.png
2020-01-10 14:29 x42 Note Added: 0020908
2020-01-10 17:52 sciurius Note Added: 0020909
2020-01-10 18:00 x42 Note Added: 0020910
2020-01-10 18:00 x42 Assigned To => x42
2020-01-10 18:00 x42 Status new => resolved
2020-01-10 18:00 x42 Resolution open => fixed