View Issue Details

IDCategoryLast Update
0007852bugs2020-04-19 20:18
ReporterahmsAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformSome Other LinuxOSSome Other LinuxOS Versionunknown
Product Version5.12 
Fixed in Version 
Summary0007852: General Midi Synth has ghost-effect modulation applied on its playback
DescriptionA midi track playing the General Midi Synth instrument should not be playing with a modulation effect if Ardour does not record the modulation effect.
Steps To ReproduceSimple setup:
1 Midi controller, 1 Midi track with the default synth.

Create a new session, set the Modulation wheel on the midi controller to max..

- Create a recording. -- Press some midi notes for several seconds.

- Stop the recording -- auto-return back to the beginning of the midi track.

Now click 'A'/Show all existing automations. << Nothing shows.

Now playback the Midi track and Ardour plays the default synth instrument with the modulation effect, even though modulation has not been recorded.

Save and close the session, re-open it and play the Midi track, there is no Modulation playback.

As expected there is still no 'A'/Show existing automations'.

This can't be a feature.. and has to be a bug..

Ardour should not be remembering the current state of the modulation when performing "playback" if it shows nothing recorded for modulation cc-1
TagsNo tags attached.

Activities

x42

2019-11-19 04:04

administrator   ~0020824

Already fixed in Ardour6/git and gmsynth v0.4.0

system

2020-04-19 20:18

developer   ~0023806

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2019-11-19 03:53 ahms New Issue
2019-11-19 04:04 x42 Assigned To => x42
2019-11-19 04:04 x42 Status new => resolved
2019-11-19 04:04 x42 Resolution open => fixed
2019-11-19 04:04 x42 Note Added: 0020824
2020-04-19 20:18 system Note Added: 0023806
2020-04-19 20:18 system Status resolved => closed