View Issue Details

IDCategoryLast Update
0007816bugs2019-09-29 17:09
ReporterahmsAssigned Tox42 
Reproducibilityalways 
Status resolvedResolutionno change required 
PlatformSome Other LinuxOSSome Other LinuxOS Versionunknown
Product Version 
Fixed in Version 
Summary0007816: can't load plugin in ardour6 beta
DescriptionThere's a plugin called 'loomer shift2' which cannot load in ardour6 -- this plugin however can load in Mixbus32c.

According to ardour's manual 'getting plugins' Loomer is mentioned, so my understanding is these plugins should just work.

If it works in mixbus32c it should also work in ardour..

not sure what else to look for -- I re-scanned the plugins folder and still outta luck..

please take a look into -- they offer demos of their plugins and I recently just purchased this plugin.

thanks
TagsNo tags attached.

Activities

x42

2019-09-28 14:38

administrator   ~0020778

Does it work in Ardour 5.12 (the most recent release)?
How does it fail? is there a message in Menu > Window > Log?
Did you explicitly scan for the plugin, or is auto-scan enabled in Preferences > Plugins > VST?
Does cleaning the blacklist and re-scanning discover the plugin?

does `ldd path/to/the/plugin.so` show missing libs? How about `LD_LIBRARY_PATH=/opt/Ardour-5.12.0/lib/ ldd path/to/the/plugin.so`


PS. At this point in time, there is still only an pre-alpha release of Ardour6, without stable session format and with countless of known bugs, some related to plugins.

ahms

2019-09-29 03:26

reporter   ~0020779

I was previously trying Ardour-6.0.pre0.2344, so I installed Ardour-6.0.pre0.2488 today and noticed this new update does not come with the default 'General Midi' synth...

ldd path/to/the/plugin.so passes successfully - so no missing dependencies.

according to the official guide from loomer's pdf, the user only needs to ensure packages libfreetype, libasound, and libXinerama are installed, which are normally found by default on any linux distribution..

ahms

2019-09-29 03:31

reporter   ~0020780

The "shift2" plugin does not get listed in the plugin list.. so yeah I did a clear cache, and path-checked ~/.vst, ~/.vst3 and did a rescan, and I still can't list this plugin in either of Ardour-6.0.pre0.2344 or Ardour-6.0.pre0.2488 (gcc5 builds)

Ardour5 cannot run here on Debian since I upgraded it to version 10.. (both the .deb build of Ardour and the .run bundle cannot run on debian 10 -- I'm using 64-bit)

x42

2019-09-29 14:45

administrator   ~0020781

I just tried myself, debian10 (buster) Ardour nightly build (6.0-pre0-2488, gcc5 64bit) + Shift2 VST. It scans and works just fine.
I've used https://www.loomer.co.uk/downloads/Shift2/Shift2_x86_64-2.3.1.tar.gz

From Window > Log . Can you copy/paste the "[INFO]: VST Blacklist:" ?

ahms

2019-09-29 16:45

reporter   ~0020782

If I rename ~/.config/ardour6 to ardour6_old, start ardour6 and add ~/.vst to the vst paths , then Shift2 shows up
 -- so Shift2 shows up with 6.0-pre0-2488 with a newly created Ardour6 configuration when ~/.config/ardour6 does not exists.

... so why does that make a difference? I'm not able to see "Shift2" blacklisted and it does not list with ~/.config/ardour6_old when I rename it back to ~/.config/ardour6

I also cleared out ~/.cache/ardour6 ...

Maybe a previous boot I could of had an ardour crash/system stall at some point -- does ardour perform sanity checks of its configuration files?

"INFO]: VST Blacklist:
/usr/lib/lxvst/libsitala.so
/home/user/.vst/lsp-plugins/lsp-plugins-vst-core-1.1.10.so
/home/user/.vst/lsp-plugins/lsp-plugins-r3d-glx.so
/home/user/.vst/glitch2/glitch2.so
/home/user/.vst/renoise_redux_demo.so
/home/user/.vst/rpl/Plugins/reaper_midi.so
/home/user/.vst/rpl/Plugins/rubberband.so
/home/user/.vst/rpl/Plugins/reaper_csurf.so
/home/user/.vst/rpl/Plugins/reaper_opus.so
/home/user/.vst/rpl/Plugins/reaper_explorer.so
/home/user/.vst/rpl/Plugins/jsfx.so
/home/user/.vst/rpl/Plugins/reaper_flac.so
/home/user/.vst/rpl/Plugins/FX/reagate.vst.so
/home/user/.vst/rpl/Plugins/FX/reatune.vst.so
/home/user/.vst/rpl/Plugins/FX/reavoice.vst.so
/home/user/.vst/rpl/Plugins/FX/reasurround.vst.so
/home/user/.vst/rpl/Plugins/FX/reapitch.vst.so
/home/user/.vst/rpl/Plugins/FX/reacast.vst.so
/home/user/.vst/rpl/Plugins/FX/reainsert.vst.so
/home/user/.vst/rpl/Plugins/FX/reavocode.vst.so
/home/user/.vst/rpl/Plugins/FX/readelay.vst.so
/home/user/.vst/rpl/Plugins/FX/reaverbate.vst.so
/home/user/.vst/rpl/Plugins/FX/reaeq.vst.so
/home/user/.vst/rpl/Plugins/FX/reaverb.vst.so
/home/user/.vst/rpl/Plugins/FX/reasynth.vst.so
/home/user/.vst/rpl/Plugins/FX/reaninjam.vst.so
/home/user/.vst/rpl/Plugins/FX/reacontrolmidi.vst.so
/home/user/.vst/rpl/Plugins/FX/reacomp.vst.so
/home/user/.vst/rpl/Plugins/FX/reafir.vst.so
/home/user/.vst/rpl/Plugins/FX/reastream.vst.so
/home/user/.vst/rpl/Plugins/FX/reaxcomp.vst.so
/home/user/.vst/rpl/Plugins/FX/reasyndr.vst.so
/home/user/.vst/rpl/Plugins/FX/reasamplomatic.vst.so
/home/user/.vst/rpl/Plugins/reaper_ogg.so
/home/user/.vst/rpl/Plugins/reaper_wave.so
/home/user/.vst/rpl/Plugins/reaper_mp3dec.so
/home/user/.vst/rpl/Plugins/elastique3.so
/home/user/.vst/rpl/Plugins/reaper_video.so
/home/user/.vst/rpl/Plugins/reaper_wavpack.so
/home/user/.vst/rpl/Plugins/soundtouch.so
"

ahms

2019-09-29 16:54

reporter   ~0020783

ok it shows up with ardour6_old ,
cd ~/.config/ardour6/plugin_metadata,
rm *
I do not know if it also made a difference to rm sfdb along with this (it was already zero bytes)

currently here I do not see the general midi synth for the 6.0-pre0-2488 build..

x42

2019-09-29 17:09

administrator   ~0020784

Thanks for the heads up!

Sadly, things like these are expected with pre-alpha versions. The config format isn't frozen yet either and subject to change.

Please re-read the pre-release dialog that shows when you launch Ardour, in particular item 4.
Strictly speaking we still ask users to not even report bugs at this point in time. It mainly just wastes time and delays Ardour6 further.

Still, I'm glad you've figured it out. Have fun with the plugin!

Issue History

Date Modified Username Field Change
2019-09-28 11:41 ahms New Issue
2019-09-28 14:38 x42 Note Added: 0020778
2019-09-29 03:26 ahms Note Added: 0020779
2019-09-29 03:31 ahms Note Added: 0020780
2019-09-29 14:45 x42 Note Added: 0020781
2019-09-29 16:45 ahms Note Added: 0020782
2019-09-29 16:54 ahms Note Added: 0020783
2019-09-29 17:09 x42 Note Added: 0020784
2019-09-29 17:09 x42 Assigned To => x42
2019-09-29 17:09 x42 Status new => resolved
2019-09-29 17:09 x42 Resolution open => no change required