View Issue Details

IDCategoryLast Update
0007788bugs2019-08-17 17:47
ReporterjpcimaAssigned Tox42 
Reproducibilityalways 
Status resolvedResolutionfixed 
PlatformLinuxOSArch x86_64OS Versionunknown
Product Version5.12 
Fixed in Version 
Summary0007788: Slider reacting strangely to LV2 property epp:rangeSteps
DescriptionWhen epp:rangeSteps is set on a control parameter, the slider in the generic UI reacts in stuttery manner, as if it resists to the mouse movement.

It was discovered while hosting a LV2 plugin built with faust2lv2.
https://www.youtube.com/watch?v=hKRucqEz-sA

The faust generator emits the epp:rangeSteps property for its controls.
Steps To ReproduceIt can be reproduced with a very simple faust program, such as the one attached
Build it with faust2lv2, and manipulate the slider in the generic UI to observe the problem.

The faust compiler was the version 2.15.11.
Tagslv2

Activities

jpcima

2019-08-17 15:44

reporter  

volume.dsp (94 bytes)

jpcima

2019-08-17 15:56

reporter   ~0020725

attached: a LV2 manifest generated from the example faust file

volume.ttl (1,313 bytes)

x42

2019-08-17 15:58

administrator   ~0020726

Likely already fixed in ardour git since https://github.com/Ardour/ardour/commit/0e79253412af587eb6cd8f3f72b841f5517dd47c
Commits before and after are related 14517e13ecb16051 (range step rounding) and 9cf9833a93f5af0 (log-scale + spinboxes).

jpcima

2019-08-17 17:40

reporter   ~0020727

I confirm that Ardour 5.12 + the commit 0e79253 has fixed the problem. The slider movement is smooth.
The commit diff did not apply directly on 5.12 source, but was fine with minor editing.

x42

2019-08-17 17:47

administrator   ~0020728

Thanks for testing. marking as resolved

Issue History

Date Modified Username Field Change
2019-08-17 15:44 jpcima New Issue
2019-08-17 15:44 jpcima Tag Attached: lv2
2019-08-17 15:44 jpcima File Added: volume.dsp
2019-08-17 15:56 jpcima File Added: volume.ttl
2019-08-17 15:56 jpcima Note Added: 0020725
2019-08-17 15:58 x42 Note Added: 0020726
2019-08-17 17:40 jpcima Note Added: 0020727
2019-08-17 17:47 x42 Assigned To => x42
2019-08-17 17:47 x42 Status new => resolved
2019-08-17 17:47 x42 Resolution open => fixed
2019-08-17 17:47 x42 Note Added: 0020728