View Issue Details

IDCategoryLast Update
0007773bugs2019-09-17 17:10
ReporterdboltonAssigned Tox42 
Reproducibilitysometimes 
Status resolvedResolutionfixed 
PlatformWindows 10OSWindowsOS Version10
Product Version5.12 
Fixed in Version 
Summary0007773: Midi track range not saved with .ardour file
DescriptionWhen you close, save and reopen an Ardour file, it should look the same, including the visible range for MIDI tracks. However this is not the case.
Steps To Reproduce1. Create a new file
2. Record a MIDI track, preferably one with a wide range of notes
4. Expand the track height
3. Enter Internal Edit Mode
4. Close Ardour
5. Choose Save when prompted
6. Reopen your Ardour session
Additional InformationExpected behavior: The MIDI track should show the full range of notes (like it did when you closed the file), and the track height should be the same.
Actual behavior: The MIDI track goes back to the default view and height before you recorded.

I encounter this bug almost everyday. I think being in Internal Edit Mode when you close might be the key to reproducing.
TagsNo tags attached.

Relationships

related to 0007807 new miditrack wave/event display cone after saving 

Activities

x42

2019-07-14 16:51

administrator   ~0020696

The note-range issue should be fixed since 6.0-pre0-2059-g53c677e08f

The issue was that the note-range-min/max was only saved when manually changing the visible range (using mouse drag/drop of the MIDI scroomer).
Automatic changes (record, rec-stop) or fit to range were not saved.

x42

2019-07-14 16:52

administrator   ~0020697

I cannot reproduce the issue that the track-height does not get saved/restored.

dbolton

2019-07-19 21:25

reporter   ~0020701

x42, is it just on 6.0 that you can't reproduce the loss of custom track-height? I tried the steps listed above four times (using 5.12), and can reproduce every time.

dbolton

2019-07-19 21:26

reporter   ~0020702

Super fast fix for the note-range bug! Thank you for working on that.

x42

2019-09-17 17:10

administrator   ~0020775

Fixed in 6.0-pre0-2059-g53c677e08f

Issue History

Date Modified Username Field Change
2019-07-14 15:22 dbolton New Issue
2019-07-14 16:51 x42 Note Added: 0020696
2019-07-14 16:52 x42 Note Added: 0020697
2019-07-19 21:25 dbolton Note Added: 0020701
2019-07-19 21:26 dbolton Note Added: 0020702
2019-09-17 17:08 x42 Relationship added related to 0007807
2019-09-17 17:10 x42 Assigned To => x42
2019-09-17 17:10 x42 Status new => resolved
2019-09-17 17:10 x42 Resolution open => fixed
2019-09-17 17:10 x42 Note Added: 0020775