View Issue Details

IDCategoryLast Update
0007755bugs2019-05-12 20:30
ReporterunfaAssigned Tojohmue-eo 
Reproducibilityhave not tried 
Status resolvedResolutionfixed 
Product Version5.12 
Fixed in Version 
Summary0007755: a-Fluid Synth - Reverb is enabled when copying, but GUI doesn't update
DescriptionI've discovered that in Ardour 5.12 when I copy a istance of a-Fluid Synth that had the reverb disabled - it becomes enabled again in the copy, but the GUI still shows it as disabled.

I guess it shouldn't change in the first place, but if it has to - I'd expect the GUI to show the current state of the plug-in.
Steps To Reproduce1. Create a MIDI track with a-Fluid Synth plug-in
2. Disable it's rverb
3. Copy the plug-in and paste to another track.
4. The reverb will be audible again, btu the UI toggle will not show it.
TagsNo tags attached.

Activities

johmue-eo

2019-05-12 19:19

developer   ~0020649

Bug confirmed.

Finding: in each run() the reverb is set only if the its state has changed since the last run (self->v_port[...] == *self->port[...]). This fails when the plugin is instanciated with reverb switched off. self->v_port[...] is initialized to 0 by calloc() and the reverb state is also 0. Thus the state is not updated in run().

Fix underway.

johmue-eo

2019-05-12 19:41

developer   ~0020651

Fixed in 12808c7

The patch is applicable also to 5.12:

diff --git a/libs/plugins/a-fluidsynth.lv2/a-fluidsynth.cc b/libs/plugins/a-fluidsynth.lv2/a-fluidsynth.cc
index 3c585f2cb..06c633dee 100644
--- a/libs/plugins/a-fluidsynth.lv2/a-fluidsynth.cc
+++ b/libs/plugins/a-fluidsynth.lv2/a-fluidsynth.cc
@@ -336,6 +336,9 @@ instantiate (const LV2_Descriptor* descriptor,
        fluid_synth_set_polyphony (self->synth, 32);
        fluid_synth_set_sample_rate (self->synth, (float)rate);
 
+ fluid_synth_set_reverb_on (self->synth, 0);
+ fluid_synth_set_chorus_on (self->synth, 0);
+
        self->fmidi_event = new_fluid_midi_event ();
 
        if (!self->fmidi_event) {

johmue-eo

2019-05-12 20:30

developer   ~0020652

Fixed in 12808c7

Issue History

Date Modified Username Field Change
2019-04-26 09:31 unfa New Issue
2019-05-12 19:19 johmue-eo Note Added: 0020649
2019-05-12 19:41 johmue-eo Note Added: 0020651
2019-05-12 20:30 johmue-eo Assigned To => johmue-eo
2019-05-12 20:30 johmue-eo Status new => resolved
2019-05-12 20:30 johmue-eo Resolution open => fixed
2019-05-12 20:30 johmue-eo Note Added: 0020652