View Issue Details

IDCategoryLast Update
0007489bugs2018-06-16 14:21
ReportermendredAssigned To 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformLinuxOSKubuntuOS Version17.10
Product Version5.12 
Fixed in Version 
Summary0007489: pointer exception on startup for new project in safe mode
DescriptionArdour crashes on startup with a pointer exception.

This happens with the downloaded executable from ardour.org. So downloaded the associated source code, compiled and ran in debug mode as per instructions on ardour site. Log has been setup in pastebin - link below in additional information
Steps To ReproduceStart ardour and start new project in safe mode plugins disabled. This happens every time it is run
Additional Informationbacktrace
for 5.12
https://pastebin.com/v9WHtVkt




TagsNo tags attached.

Relationships

has duplicate 0007502 resolvedx42 crach since ubuntu upgrade 
has duplicate 0007632 closedx42 Crash while opening any project 

Activities

mendred

2017-10-14 10:45

reporter   ~0020054

Have tried getting the latest code from git and running that to see if that makes a difference - same result

x42

2017-10-14 14:19

administrator   ~0020055

Can you try if uninstalling the "csladspa" (csound ladspa plugin) package helps?

Some other Ubuntu users mentioned this on IRC before, but I don't know what exactly the issue is with it on Ubuntu.

Smells like some C++/C++11 ABI issue with the plugin using strings in the plugin descriptor.

mendred

2017-10-14 21:49

reporter   ~0020056

Yep that solved it. thanks X42 you are a star (As always!)

mendred

2017-10-14 21:50

reporter   ~0020057

Removing the csladspa plugin from ubuntu (apt remove csladspa) fixed this

Issue History

Date Modified Username Field Change
2017-10-14 10:43 mendred New Issue
2017-10-14 10:45 mendred Note Added: 0020054
2017-10-14 14:19 x42 Note Added: 0020055
2017-10-14 21:49 mendred Note Added: 0020056
2017-10-14 21:50 mendred Note Added: 0020057
2017-10-14 21:50 mendred Status new => closed
2017-10-14 21:50 mendred Resolution open => fixed
2018-03-18 19:12 x42 Relationship added has duplicate 0007502
2018-06-16 14:21 x42 Relationship added has duplicate 0007632