View Issue Details

IDCategoryLast Update
0007441bugs2020-04-19 20:18
ReporterArndAssigned Tox42 
Status closedResolutionfixed 
PlatformLinuxOSopenSUSEOS VersionLeap 42.2
Product Version5.10 
Fixed in Version 
Summary0007441: Option "MIDI input follows Track selection" not working
DescriptionWith Ardour 5.5 the feature "MIDI input follows Track selection" was added. I tried to use this function first with 5.10 (as well as current nightly 5.10.456), therefore I don't know whether it worked before (ie. 5.5 through 5.10).

In "Edit->Preferences" "MIDI Ports" I select "MIDI input follows MIDI track selection" and set check marks for "Music Data", "Control Data" and "Follow Selection" for my (via Jack MIDI) connected controller keyboard Novation Impulse 25.

But whatever I do the MIDI input does not follow the MIDI track selection, independent whether I assign my MIDI interface as an input to each track or leave it disconnected.
Steps To ReproduceEnter "Edit->Preferences" "MIDI Ports".
Select "MIDI input follows MIDI track selection".
Set check marks for "Music Data", "Control Data" and "Follow Selection" for the MIDI interface the controller keyboard is connected to.
Return to "Editor" view.
Create two MIDI tracks.
Assign the MIDI interface representing the controller keyboard to both tracks as input.
Enable MIDI input for both tracks.
Select first track. Expected: MIDI input only routed to first track. Result: MIDI input routed to both tracks.
Select second track. Expected: MIDI input only routed to second track. Result: MIDI input routed to both tracks.
Additional InformationI tested with the official 5.10 build (from as well as nightly build 5.10.456.
I tested using Jack (and Jack MIDI) as well as "raw" ALSA (and ALSA MIDI Raw).
No change, same behaviour.
TagsNo tags attached.



2017-08-05 22:06

administrator   ~0019959

Fixed in Ardour 5.10-464-gf25824ed2


2020-04-19 20:18

developer   ~0023770

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2017-08-05 20:58 Arnd New Issue
2017-08-05 22:06 x42 Note Added: 0019959
2017-08-05 22:06 x42 Status new => resolved
2017-08-05 22:06 x42 Resolution open => fixed
2017-08-05 22:06 x42 Assigned To => x42
2020-04-19 20:18 system Note Added: 0023770
2020-04-19 20:18 system Status resolved => closed