View Issue Details

IDCategoryLast Update
0007436features2020-04-19 20:18
ReporterOnkelDeadAssigned Toovenwerks 
ReproducibilityN/A 
Status closedResolutionfixed 
PlatformanyOSOS Version
Product Version5.10 
Fixed in Version 
Summary0007436: OSC: add filed to plugin_list response which indicates plugin enable state
DescriptionA OSC surface should be informed about the plugin enable state if it requests the list of plugins.
TagsNo tags attached.

Activities

OnkelDead

2017-07-31 10:56

reporter  

plugin_list.patch (411 bytes)
diff --git a/libs/surfaces/osc/osc.cc b/libs/surfaces/osc/osc.cc
index 09939fd..954b7ed 100644
--- a/libs/surfaces/osc/osc.cc
+++ b/libs/surfaces/osc/osc.cc
@@ -4037,6 +4037,7 @@ OSC::route_plugin_list (int ssid, lo_message msg) {
 
 		boost::shared_ptr<ARDOUR::Plugin> pip = pi->plugin();
 		lo_message_add_string (reply, pip->name());
+		lo_message_add_int32(reply, redi->enabled() ? 1 : 0);
 
 		piid++;
 	}
plugin_list.patch (411 bytes)

ovenwerks

2017-08-01 14:13

reporter   ~0019945

Merged in commit e4925a90c

system

2020-04-19 20:18

developer   ~0023769

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2017-07-31 10:56 OnkelDead New Issue
2017-07-31 10:56 OnkelDead File Added: plugin_list.patch
2017-08-01 14:13 ovenwerks Note Added: 0019945
2017-08-01 14:13 ovenwerks Status new => resolved
2017-08-01 14:13 ovenwerks Resolution open => fixed
2017-08-01 14:13 ovenwerks Assigned To => ovenwerks
2020-04-19 20:18 system Note Added: 0023769
2020-04-19 20:18 system Status resolved => closed