View Issue Details

IDCategoryLast Update
0007410bugs2020-04-19 20:18
ReporterribanAssigned Toovenwerks 
Reproducibilityalways 
Status closedResolutionfixed 
Platformi86-64OSWindowsOS Version7
Product Version5.10 
Fixed in Version 
Summary0007410: OSC set_surface not configuring feedback
DescriptionSending a "set_surface" OSC message does not set the feedback mode but instead Ardour uses the default feedback mode set in the application settings.
Steps To ReproduceClear default OSC feedback settings, e.g. select "Ardour Factory Setting" for OSC preset.
Press "Clear OSC Devices" button in the OSC Control Protocol Settings dialog (to remove any existing mapping for control surfaces).
Start OSC application and send "/set_surface iiiiii 0 63 179 1 0 0".
Expected result: Feedback is sent for strip buttons, strip variables, master section, bar beat, meter (dB).
Actual result: No feedback is sent.
Additional InformationChanging the default feedback changes what feedback is sent to the OSC device which indicates that Ardour is ignoring the feedback requested by "set_surface" and using the default settings.

In Ardour log the following messages are logged when "set_surface" is sent:

[WARNING]: OSC: Plugin: 0 does not seem to be a plugin
[INFO]: OSC: /set_surface i:0 i:63 i:179 i:1 i:0 i:0

Using "/set_surface/0/63/179/1/0 i:0" does work so it seems using individual integer elements is triggering this issue.
TagsNo tags attached.

Activities

ovenwerks

2017-07-01 02:26

reporter   ~0019847

Commit 41bc5bc116c4137053d078484010092355d67a0e should fix this. It seems the optimized build requires different ways of doing things. Tomorrows nightly will have this fix included.

system

2020-04-19 20:18

developer   ~0023760

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2017-06-30 07:42 riban New Issue
2017-07-01 02:26 ovenwerks Note Added: 0019847
2017-07-01 02:26 ovenwerks Status new => resolved
2017-07-01 02:26 ovenwerks Resolution open => fixed
2017-07-01 02:26 ovenwerks Assigned To => ovenwerks
2020-04-19 20:18 system Note Added: 0023760
2020-04-19 20:18 system Status resolved => closed