View Issue Details

IDCategoryLast Update
0007349bugs2017-05-12 02:49
Reportergraydw57Assigned To 
Reproducibilityalways 
Status closedResolutionduplicate 
PlatformAMD64OSUbuntu LinuxOS Version16.04
Product Version5.X git (version in description) 
Fixed in Version 
Summary0007349: GUI thread crashes when Editor List window is at minimum size
DescriptionArdour5.8.700 (built using 5.8-700-g2b33d35 and GCC version 5.4.0 20160609)

When (and only when) using a high scale factor reducing the editor list window to minimum size causes the GUI thread to crash. A "FATAL ERROR" dialog pops up - with no text in it. The GUI no longer updates. The controls are still live, you can play a track but nothing changes on screen. The program does NOT exit. (If you're in full screen, it's a major effort to kill the program.

Reducing the editor screen can be by double clicking on one of the labels on the far right side, or by dragging the left edge to the right.

Once this happens, you can no longer restart ardour - it crashes as soon as the main window paints. You can fix this by editing the instant.xml file in the config directory, and set the edit-horizontal-pane-position entry - setting it the same as the vertical entry is sufficient.

Again, this does NOT happen at 100% scale, but on my monitor I need to use the max scale position to make ardour usable.
Steps To ReproduceSet the scale in edit-preferences-appearance to maximum. Restart ardour to re-layout. Double click on any header in the editor list (Regions or Tracks & Busses or any of the others.) Immediate "fatal error" dialog and the GUI is dead. Or grab the left edge of the list window and move it to the right all the way. Same result.
Additional InformationIt looks like the edit-horizontal-pane-position is out of range?
TagsNo tags attached.

Relationships

duplicate of 0007040 new dragging editor list panel to the far right crashes Ardour 

Activities

graydw57

2017-05-11 01:45

reporter  

instant.xml.samples (3,843 bytes)

timbyr

2017-05-11 23:12

developer   ~0019675

This seems like a duplicate of http://tracker.ardour.org/view.php?id=7040

Would you agree?

graydw57

2017-05-12 02:08

reporter   ~0019677

I would agree, with the proviso that it requires the scale factor to be > 100% - at 100% it works OK. At max (which i have to use) it crashes.

timbyr

2017-05-12 02:49

developer   ~0019678

Closing as duplicate, please add any new comments to original report. Thanks.

Issue History

Date Modified Username Field Change
2017-05-11 01:45 graydw57 New Issue
2017-05-11 01:45 graydw57 File Added: instant.xml.samples
2017-05-11 23:12 timbyr Note Added: 0019675
2017-05-12 02:08 graydw57 Note Added: 0019677
2017-05-12 02:48 timbyr Relationship added duplicate of 0007040
2017-05-12 02:49 timbyr Note Added: 0019678
2017-05-12 02:49 timbyr Status new => closed
2017-05-12 02:49 timbyr Resolution open => duplicate