View Issue Details

IDCategoryLast Update
0007228bugs2020-04-19 20:18
ReportercolinfAssigned Topaul 
Reproducibilityhave not tried 
Status closedResolutionfixed 
Product Version5.X git (version in description) 
Fixed in Version 
Summary0007228: Region trim operations disabled when there's a track selection
DescriptionIt used to be possible to use, for example, 'J' and 'K' to trim all regions on selected tracks at the edit point, but these now appear to be disabled when the region selection is empty.

TagsNo tags attached.


related to 0007077 assignedpaul Right click context menu over region usable only in some modes 



2017-02-07 16:24

administrator   ~0019338

should be fixed in git now.


2017-02-07 16:29

updater   ~0019340

Hmm, still doesn't work for me: all region trim menu items are still disabled when there's a track selection.

Also, I reckon that at least 'Trim to Loop' and 'Trim to Punch' should also be enabled in this case.


2017-02-07 16:34

administrator   ~0019342

ah right, i thought that just not calling "reg_sens()" on them was enough. it isn't. there needs to be a new group .... coming up.


2017-02-10 21:13

administrator   ~0019361

this is much harder than it looked. here are some notes i made while hacking on an experimental branch ...

problem is that when calling
sensitize_the_right_region_actions(), we call
get_regions_from_selection_and_edit_point() but with arguments
that may differ from those used to make the same call when an
action is actually carried out.

this means that get_regions_from_selection_and_edit_point() may return
different results in each context, which means that an action which
was shown as relevant (sensitive) in a menu may in fact do nothing.

secondarily, many operations use
get_regions_from_selection_and_entered(), not
get_regions_from_selection_and_edit_point() which means that the set
of regions potentially affected by an action depends on the action
itself and cannot be generalized.


2017-02-16 09:31

administrator   ~0019402

Things should be much better as of 606c8d4

This took quite a hard engineering effort. I suspect there may still be ways to improve the overall code internally, but I think this now functions as expected from a user perspective.


2017-07-19 14:14

updater   ~0019902

Yes, working for ages now: cheers!


2020-04-19 20:18

developer   ~0023715

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2017-02-06 19:56 colinf New Issue
2017-02-07 13:06 colinf Description Updated View Revisions
2017-02-07 16:24 paul Note Added: 0019338
2017-02-07 16:24 paul Assigned To => paul
2017-02-07 16:24 paul Status new => feedback
2017-02-07 16:29 colinf Note Added: 0019340
2017-02-07 16:29 colinf Status feedback => assigned
2017-02-07 16:34 paul Note Added: 0019342
2017-02-10 21:13 paul Note Added: 0019361
2017-02-13 11:51 colinf Relationship added related to 0007077
2017-02-16 09:31 paul Note Added: 0019402
2017-02-16 09:31 paul Status assigned => feedback
2017-07-19 14:14 colinf Note Added: 0019902
2017-07-19 14:14 colinf Status feedback => assigned
2017-07-19 14:14 colinf Status assigned => resolved
2017-07-19 14:14 colinf Resolution open => fixed
2020-04-19 20:18 system Note Added: 0023715
2020-04-19 20:18 system Status resolved => closed