View Issue Details

IDCategoryLast Update
0007209bugs2020-04-19 20:18
ReporterbeefheartAssigned Topaul 
Reproducibilityalways 
Status closedResolutionwon't fix 
PlatformLinuxOSManjaroOS Version
Product Version5.5 
Fixed in Version 
Summary0007209: Problem with ardour's libglibmm version, plugin UI unable to load
DescriptionI have noticed a problem when using the guitarix plugins. When I try to load one of the UIs for these plugins nothing happens and the log shows: "[ERROR]: failed to instantiate LV2 GUI".

When running ardour from a terminal this is displayed: suil error: Unable to open UI library /usr/lib/lv2/gx_delay.lv2/gx_delay_gui.so (/usr/lib/lv2/gx_delay.lv2/gx_delay_gui.so: undefined symbol: _ZN4Glib17SignalProxyNormal13connect_impl_EbON4sigc9slot_baseEb)

I spoke to rgareus about this briefly on the irc channel and he thought it was because of ardour's glibmm version.
My system has glibmm 2.50.0-1.

I have compiled ardour myself from git and this problem is not present so it looks to be a problem with the official ardour builds.

I also notice this in the log when ardour starts, I don't know if it is related:
[ERROR]: LADSPA: cannot load module "/usr/lib/ladspa/ladspa_guitarix.so" (/usr/lib/ladspa/ladspa_guitarix.so: undefined symbol: _ZN4Glib10Dispatcher7connectEON4sigc4slotIvNS1_3nilES3_S3_S3_S3_S3_S3_EE)
[ERROR]: LADSPA: cannot load module "/usr/lib/ladspa/ladspa_guitarix.so" (/usr/lib/ladspa/ladspa_guitarix.so: undefined symbol: _ZN4Glib10Dispatcher7connectEON4sigc4slotIvNS1_3nilES3_S3_S3_S3_S3_S3_EE)
Steps To ReproduceInstall guitarix from the regular arch/manjaro repo.
Install ardour build from official source.
Open ardour and load of the gx plugins.
Try to open the UI of the plugin - nothing happens.
TagsNo tags attached.

Activities

x42

2017-01-19 23:08

administrator   ~0019290

Last edited: 2017-01-19 23:10

View 2 revisions

That's likely a won't-fix. Plugins are supposed to be self-contained and not depend on external libraries.

for the case at hand "_ZN4Glib17SignalProxyNormal13connect_impl_EbON4sigc9slot_baseEb" aka Glib::SignalProxyNormal::connect_impl_(bool, sigc::slot_base&&, bool)
was only added in glib 2.48: https://developer.gnome.org/glibmm/stable/classGlib_1_1SignalProxyNormal.html#aabce0a7d8c60c4fd3020a22f63c72a10

paul

2017-01-22 21:08

administrator   ~0019296

see x42's comment.

system

2020-04-19 20:18

developer   ~0023707

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2017-01-19 22:42 beefheart New Issue
2017-01-19 23:08 x42 Note Added: 0019290
2017-01-19 23:10 x42 Note Edited: 0019290 View Revisions
2017-01-22 21:08 paul Note Added: 0019296
2017-01-22 21:08 paul Status new => resolved
2017-01-22 21:08 paul Resolution open => won't fix
2017-01-22 21:08 paul Assigned To => paul
2020-04-19 20:18 system Note Added: 0023707
2020-04-19 20:18 system Status resolved => closed