View Issue Details

IDCategoryLast Update
0007165features2017-11-24 08:15
ReporterunfaAssigned Tox42 
Reproducibilityalways 
Status resolvedResolutionwon't fix 
Product Version5.5 
Fixed in Version 
Summary0007165: Allow looping when synced to JACK transport
DescriptionI don't know why but looped playback is disabled when syncing to JACK transport.

I'm using Ardour in sync with Blender and sometimes looping a part of the session would be great - I could tune the sound timing while watching the video in Blender.

Why is this disabled? If it's dangerous and breaks some JACK-transport enabled programs, could it be optional, but still possible?
TagsNo tags attached.

Activities

x42

2017-11-18 00:44

administrator   ~0020090

Jack transport cannot loop (by design) Trying to make it loop will fail one way or another. (Yes we tried, it cannot be made to work reliably and hence was disabled)

unfa

2017-11-24 08:15

reporter   ~0020094

Last edited: 2017-11-24 08:15

View 2 revisions

I see.

Is is possible to make Ardour loop it's internal transport based on JACK?

For example Hydrogen will loop it's project, when JACK transport position exceeds it's length. If Ardour could do the same, based on the Loop markers, it'd do the job.

JACK Transport would go forward, but maybe Ardour could wraparound it's transport like Hydrogen does?

Issue History

Date Modified Username Field Change
2016-12-09 14:27 unfa New Issue
2017-11-18 00:44 x42 Note Added: 0020090
2017-11-18 00:45 x42 Status new => resolved
2017-11-18 00:45 x42 Resolution open => won't fix
2017-11-18 00:45 x42 Assigned To => x42
2017-11-24 08:15 unfa Note Added: 0020094
2017-11-24 08:15 unfa Note Edited: 0020094 View Revisions