View Issue Details

IDCategoryLast Update
0007153bugs2020-04-19 20:18
ReportertimbyrAssigned Totimbyr 
Reproducibilityalways 
Status closedResolutionfixed 
Product Version5.4 
Fixed in Version 
Summary0007153: Use Duplicate action that operates dependent on context by default with Alt+d key binding
DescriptionIf some regions are selected then by default Alt+d will duplicate one or more
Regions. If I am using the range selection tool then my expectation is that
Alt+d will duplicate the range selection.

Currently this is not the case as Duplicate Range has a separate key binding
that can be assigned. As I use Duplicate Range more frequently and I feel it is
generally more useful I assign the Alt+d key binding to Duplicate Range.

I was somewhat surprised that Duplicate Range will also duplicate a Region
Selection and so does what I sort of expected and am suggesting in the title
already.

So I think we should rename the 'Duplicate Range' action to just 'Duplicate'
and possibly remove the Duplicate Region action or if it is needed for some
reason then at least change the default key binding for Alt+d to the renamed
'Duplicate' action.
TagsNo tags attached.

Activities

timbyr

2016-11-30 11:51

developer   ~0019094

I have a patch series that implements these suggestions and fixes a few other small issues. I'll push to master after release of 5.5 for testing etc.

timbyr

2016-12-06 04:46

developer   ~0019118

This bug/feature is now implemented in master@a7d19f8f and will be an a nightly build >= 5.5.36 along with Multi-Duplicate for range selections.

system

2020-04-19 20:18

developer   ~0023688

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-11-29 12:33 timbyr New Issue
2016-11-30 11:49 timbyr Assigned To => timbyr
2016-11-30 11:49 timbyr Status new => assigned
2016-11-30 11:51 timbyr Note Added: 0019094
2016-12-06 04:46 timbyr Note Added: 0019118
2016-12-06 04:46 timbyr Status assigned => resolved
2016-12-06 04:46 timbyr Resolution open => fixed
2020-04-19 20:18 system Note Added: 0023688
2020-04-19 20:18 system Status resolved => closed