View Issue Details

IDCategoryLast Update
0007096bugs2016-11-29 10:42
ReporterzettberlinAssigned To 
Reproducibilityrandom 
Status feedbackResolutionopen 
PlatformLinuxOSUbuntuOS Version15.10
Product Version5.4 
Fixed in Version 
Summary0007096: Timestretch crashes Ardour
DescriptionStreching a stereoregion as "multitimbral mixture" crashes Ardour like this:

RBEffect: source region: position = 3744000, start = 6630216, length = 168000, ancestral_start = 0, ancestral_length = 0, stretch 1, shift 1
StretchCalculator::calculate(): inputDuration 168000, ratio 1.14286, outputDuration 192000 (rounded up to 192082), df size 564, increment 298
total input increment = 168072 (= 564 chunks), output = 192082, ratio = 1.14286, ideal output 192083
(region total = 192082)
2 threads created
Speicherzugriffsfehler (Speicherabzug geschrieben)
Steps To ReproduceUse the time stretch tool, it happens occasionally but often enough to destroy any workflow.
Additional InformationCrashes and other more or less severe errors are making the timestretch tool a adventourous feature at best for about 10 years now...
TagsNo tags attached.

Activities

timbyr

2016-11-13 11:14

developer   ~0018949

Is this using an official build of 5.4?

I tried to reproduce this issue with 5.4 using the "Balanced multitimbral mixture" mode, stretching an audio region about 20 times between 1.05 and 2.5 times and could not produce a crash.

How occasionally does this occur for you?

Is it possible for you to download a nightly debug build and try to get a backtrace of the crash so we can determine the cause?

zettberlin

2016-11-13 20:02

reporter   ~0018953

It happens very rarely but I use the timestretch often and thus it crashes way too often for me. As in: 2-3 times in 100h of working with Ardour.
I also tend to use the stretch extremely, 3-4 times the original length for special effects. But this time I only tried to lengthen a region by about 60%...

I will build a GIT checkout with debug symbols ASAP and try to reproduce it...

x42

2016-11-28 15:08

administrator   ~0019086

Any news on this?

The qm-dsp lib which used for time-stretching and bundled with Ardour was updated with Ardour 5.4-56-g485e31f (early Oct'16) and may fix this.

Issue History

Date Modified Username Field Change
2016-11-07 22:03 zettberlin New Issue
2016-11-13 11:14 timbyr Note Added: 0018949
2016-11-13 11:14 timbyr Status new => feedback
2016-11-13 20:02 zettberlin Note Added: 0018953
2016-11-13 20:02 zettberlin Status feedback => new
2016-11-28 15:08 x42 Note Added: 0019086
2016-11-29 10:42 timbyr Status new => feedback