View Issue Details

IDCategoryLast Update
0007079bugs2020-04-19 20:18
Reporterpatmalcolm91Assigned Topaul 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformUbuntuOSLinuxOS VersionMaverick
Product Version5.4 
Fixed in Version 
Summary0007079: Presonus Faderport Solo Button Does Not Work
DescriptionAfter setting up the Presonus Faderport, all controls and buttons work as expected, except the solo button has no effect.
TagsNo tags attached.

Activities

mhartzel

2016-10-31 21:35

reporter   ~0018895

I can confirm this with Ardour 5.4.252. I have a brand new Faderport I just connected to my computer the first time.

The solo button lights up on the Faderport if the selected track is soloed clicking the track solo in Ardour, but pressing solo button on the Faderport does nothing in Ardour.

mhartzel

2016-12-09 18:51

reporter   ~0019137

Issue still exists in Ardour 5.5 downloaded from Ardour.org.

In the Midi Tracer window I can see that FaderPort sends midi command "Polypressure chn 1 11" when the solo button on is pressed. The solo state of selected the track does not change however. Rec and Mute buttons pressed on FaderPort correctly changes track state.

paul

2016-12-19 22:51

administrator   ~0019182

Please get a debug build (from nightly.ardour.org if necessary), and run from the command line with -D faderport added to the command. Then attach the output when you press the solo button.

mhartzel

2016-12-20 17:04

reporter   ~0019199

The Faderport solo button works on Ardour 5.5.242 :) The fix in commit 7b9d3f94d4649cb34fcf762eb03282ddbf890025 seems to have nailed it.

Thanks Paul :)

paul

2016-12-20 17:11

administrator   ~0019200

see notes.

system

2020-04-19 20:18

developer   ~0023664

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-10-27 03:40 patmalcolm91 New Issue
2016-10-31 21:35 mhartzel Note Added: 0018895
2016-12-09 18:51 mhartzel Note Added: 0019137
2016-12-19 22:51 paul Note Added: 0019182
2016-12-19 22:51 paul Assigned To => paul
2016-12-19 22:51 paul Status new => feedback
2016-12-20 17:04 mhartzel Note Added: 0019199
2016-12-20 17:11 paul Note Added: 0019200
2016-12-20 17:11 paul Status feedback => resolved
2016-12-20 17:11 paul Resolution open => fixed
2020-04-19 20:18 system Note Added: 0023664
2020-04-19 20:18 system Status resolved => closed