View Issue Details

IDCategoryLast Update
0007026bugs2016-11-01 14:39
Reporterherr_doktorAssigned To 
Reproducibilityrandom 
Status closedResolutionfixed 
PlatformPCOSDebianOS VersionJessie 32 and 64
Product Version5.3 
Fixed in Version 
Summary0007026: +40 db noise appears randomly when starting playback
DescriptionIt only appears with Virtual instruments with a post send (actually drumgizmo with post send to a verb. Doesn't depend on the verb, I've tried with several different ones, LXVST, LADSPA or LV2, I've got the problem randomly, let say one out of three playback starts). It appears in the instrument tracks, and de facto in the verb bus. I suspect a loopback issue (due to A5 or the instrumennt, I cannot say). It may be an Ardour issue as well as a Drumgizmo issue but I think it could be a safe feature to implement an automute on the master when level exceeds a given level: Could be a safe trick for tweeters and ears...
Steps To ReproduceDrumgizmo with individual routing to tracks for each output. Put some post sends from snare, OH etc to a verb bus, then start stop start several times and get your hand on the mute button... I'll post an anim GIF ASAP if it can help. (BTW, DG is the only instrument Ive got, so I cannot say if it's just with DG or with virtual instruments, generally speaking)
TagsNo tags attached.

Activities

x42

2016-09-13 14:29

administrator   ~0018629

With Drumgizmo there is/was a known issue: it does not zero the output buffers, so you can get random noise if it's not writing samples or no kit is loaded. This has been fixed in DG git a few months ago.

As for comparing: With Ardour 5.3, you should have at least 3 instruments which are bundled with Ardour: "a-Reasonable Synth", "Simple Synth" and "a-Fluid Synth" (which needs a .sf2 soundfont).

What Reverb are you using? If you use calf-reverb, try a-reverb, zita-rev1 or IR.lv2.


PS. In A5.x meters are capped at +40dBFS so that fall-off time becomes finite. The actual signal may be larger, but will be truncated to 0dBFS at the output anyway.

herr_doktor

2016-09-13 18:14

reporter   ~0018632

Tried with Mverb, protoverb, calf, A-reverb, klanfalten, IR,... with the exact same result. My DG is up to date. I'll try with fluid synth and will report the result.

deva

2016-09-14 13:27

reporter   ~0018639

Which version of DrumGizmo are you using? (hint: you can see it at the bottom of the plugin window)
Also; what samplerate are your session configured to, and which drumkit did you load into DrumGizmo?

x42

2016-09-14 13:29

administrator   ~0018640

Information about Routing (sends or port-connections) and as much information as possible to reproduce it would be helpful. A screenshot maybe.

Ideally a recipe how to reproduce this: step by step starting with session-creation.

herr_doktor

2016-09-15 22:20

reporter   ~0018654

https://dl.dropboxusercontent.com/u/16041378/ardour-dg-40db.gif

it's a 50 meg anim gif showing the issue while starting a new session from zero; it is quite long before the problem occurs, but it commonly appears more often with my others sessions. As you can see, it's the latest official DG. I think you'll understand easily the way everything is connected.

Deva: I always work in 44.100. In the example, the kit is a 44.100 kit (shittykit in this case but I've tried with others: same issue).

Hope this can help debugging (if I did did something wrong, I apologize. But I'm 99% sure my routings are OK). If I find time, I'll try with another instrument tomorrow.

x42

2016-09-15 22:58

administrator   ~0018655

too bad, that gif is not a video that one can seek/stop: I've missed if the x-run counter bumps at the end when the peak occurs.

Near the end it looks like it's DG's output that's peaking on all channels. That's good info! I thought it's only the reverb bus -- after the reverb. and not the source.

I do not have a spontaneous idea how to debug this, I'll sleep over it.

..but a quick hint: Don't use "strict I/O" (E/S strict) when creating the MIDI track. With "flexible I/O" you get all channels directly (no need to make pin connections manually). If you do want a dedicated channel count, after adding ports: right-click and "reset" in the Pin Dialog that connects all pins 1:1 in one go.

deva

2016-09-16 06:01

reporter   ~0018660

Are you using the lv2 or lxvst version of DG?

herr_doktor

2016-09-16 10:24

reporter   ~0018662

(Thx, I'll keep in mind the trick for flexible I/O)

This is why I cannot affirm it's a Ardour bug: The midi track outputs are getting wild too, and this is not coherent with an internal Ardour feedback. Nevertheless, it only occurs if there is a send on the "children tracks" to a bus. Weird.

Deva, it's LV2 version (vst version would appeared as "drumgizmo_lxvst" in the list).

herr_doktor

2016-09-16 20:15

reporter   ~0018669

Last edited: 2016-09-18 14:23

View 2 revisions

Tested with a-fluisynth (6 instances on one midi track with recreation of a similar routing): after an hour destroying my space bar with start/stop, no noise at all. So it seems to be a DG issue. Sorry Deva and Muldjord... Nevertheless, I think an automute should be implemented (even at 0dbfs, it's a pain in the ears and I'll surely need a pacemaker sooner than attended...).

x42

2016-09-18 17:42

administrator   ~0018679

It could still be some kind of edge case in Ardour for multi-channel synths, but I don't yet see how.

herr_doktor

2016-11-01 00:09

reporter   ~0018898

Solved with drumgizmo 0.9.11.

herr_doktor

2016-11-01 14:39

reporter   ~0018899

Drumgizmo 0.9.10 issue. 0.9.11 do not behave this way.

Issue History

Date Modified Username Field Change
2016-09-13 14:02 herr_doktor New Issue
2016-09-13 14:29 x42 Note Added: 0018629
2016-09-13 18:14 herr_doktor Note Added: 0018632
2016-09-14 13:27 deva Note Added: 0018639
2016-09-14 13:29 x42 Note Added: 0018640
2016-09-15 22:20 herr_doktor Note Added: 0018654
2016-09-15 22:58 x42 Note Added: 0018655
2016-09-16 06:01 deva Note Added: 0018660
2016-09-16 10:24 herr_doktor Note Added: 0018662
2016-09-16 20:15 herr_doktor Note Added: 0018669
2016-09-18 14:23 herr_doktor Note Edited: 0018669 View Revisions
2016-09-18 17:42 x42 Note Added: 0018679
2016-11-01 00:09 herr_doktor Note Added: 0018898
2016-11-01 14:39 herr_doktor Note Added: 0018899
2016-11-01 14:39 herr_doktor Status new => closed
2016-11-01 14:39 herr_doktor Resolution open => fixed