View Issue Details

IDCategoryLast Update
0007007bugs2020-04-19 20:18
Reporterjohmue-eoAssigned Tojohmue-eo 
Reproducibilityalways 
Status closedResolutionfixed 
Product Version5.3 
Fixed in Version 
Summary0007007: Faulty Undo when moving several regions by Ripple movement
DescriptionMoving one region and by that rippling a following region in the same track is not correctly undoable. At least one of the regions after undo is in the wrong place.
Steps To Reproduce* Have a session with one audio track which has two regions with a gap in between.

* Set the "Edit mode" to "Ripple"

* Move the first region (in either direction)

* Trigger "Edit->Undo"

The two regions should be in exactly the same position as before the move action. But at least one is. When moving the first region forward, the following region is not correctly reset. When moving the first region backward, the first region is not correctly rest.
Additional InformationTested on Ardour 5.3 (self compiled git commit tagged 5.3) on Ubunutu 16.04. Same behavior on latest Ardour 4.
TagsNo tags attached.

Activities

timbyr

2016-09-06 09:51

developer   ~0018550

I can confirm this issue exists in version 5.3 from ardour.org(linux 32bit)

paul

2016-09-06 20:40

administrator   ~0018553

I can't reproduce this by following these instructions. Can you attach a screenshot showing the editor window?

timbyr

2016-09-07 11:27

developer  

ardour-5.3-ripple-undo.webm (949,478 bytes)

timbyr

2016-09-07 11:29

developer   ~0018561

I attached a short video with some of the strange behaviour that I'm seeing in 5.3 when using undo after moving regions in ripple mode.

johmue-eo

2016-09-07 17:29

developer   ~0018563

That's exaclty what I meant. Thanks for making the video.

johmue-eo

2020-04-13 22:02

developer   ~0021340

Fixed in d5f25f9.

Rippling across tracks is still not working well wrt. undo/redo.

system

2020-04-19 20:18

developer   ~0023648

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-09-04 14:33 johmue-eo New Issue
2016-09-06 09:51 timbyr Note Added: 0018550
2016-09-06 09:51 timbyr Status new => confirmed
2016-09-06 20:40 paul Note Added: 0018553
2016-09-07 11:27 timbyr File Added: ardour-5.3-ripple-undo.webm
2016-09-07 11:29 timbyr Note Added: 0018561
2016-09-07 17:29 johmue-eo Note Added: 0018563
2020-04-13 22:02 johmue-eo Assigned To => johmue-eo
2020-04-13 22:02 johmue-eo Status confirmed => resolved
2020-04-13 22:02 johmue-eo Resolution open => fixed
2020-04-13 22:02 johmue-eo Note Added: 0021340
2020-04-19 20:18 system Note Added: 0023648
2020-04-19 20:18 system Status resolved => closed