View Issue Details

IDCategoryLast Update
0006984bugs2020-04-19 20:18
ReporterwoupidaAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformUbuntuOSLinuxOS VersionMaverick
Product Version5.0 
Fixed in Version 
Summary0006984: Actually version 5.1
DescriptionErrors in compilations of Ardour 5.1 source code when --windows-vst option is activated
Additional InformationSee attached file reporting the errors.
TagsNo tags attached.

Activities

woupida

2016-08-25 17:56

reporter  

waf.txt (510,633 bytes)

x42

2016-08-25 19:45

administrator   ~0018482

Fixed in Ardour 5.1-8-g48d085a

but make sure to read
http://www.manual.ardour.org/working-with-plugins/windows-vst-support/

You're basically compiling Ardour as a hybrid Windows exe. It's not a great idea for everything outside academics.

woupida

2016-08-26 09:58

reporter   ~0018490

I already read that many times.

So why not to remove the ability to compile Ardour with VST plugins handling option ?

A.

x42

2016-08-26 12:08

administrator   ~0018491

It's handy for testing, benchmarking, debugging and to get yet another compiler/debugger opinion. Same reason there's a MSVC project for Ardour, while we do use mingw x-compilation for official binaries.

There are also custom appliances: Limited set of known good plugins and a specific rt-patched version of wine; check avlinux for example.

Speaking of which: Depending on which version of the wine-headers you use, you may have to remove the "__MINGW32__" define in libs/fluidsynth/wscript (see the comment there).

The issue is known upstream at wine.

woupida

2016-08-26 15:21

reporter   ~0018492

Thanks for your answers, I was precisely thinking of AVLinux.

A.

system

2020-04-19 20:18

developer   ~0023643

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-08-25 17:56 woupida New Issue
2016-08-25 17:56 woupida File Added: waf.txt
2016-08-25 19:45 x42 Note Added: 0018482
2016-08-25 19:45 x42 Status new => resolved
2016-08-25 19:45 x42 Resolution open => fixed
2016-08-25 19:45 x42 Assigned To => x42
2016-08-26 09:58 woupida Note Added: 0018490
2016-08-26 12:08 x42 Note Added: 0018491
2016-08-26 15:21 woupida Note Added: 0018492
2020-04-19 20:18 system Note Added: 0023643
2020-04-19 20:18 system Status resolved => closed