View Issue Details

IDCategoryLast Update
0006944bugs2020-04-19 20:18
ReporterjamsAssigned Toovenwerks 
Reproducibilityalways 
Status closedResolutionno change required 
PlatformLinuxOSDebianOS VersionJessie stable
Product Version5.0-pre 
Fixed in Version 
Summary0006944: Hidden tracks from mixer or editor
DescriptionProblem to show or hide the tracks as if displays the window editor or windows mixer.
Steps To Reproduceif I go to the track on the console and I want to hide from the editor it seems that this is a problem because the action of one affects the other.
Additional InformationArdour 5.0.rc1.86
"Before and After Science"
(rev 5.0)
Intel 64 bits
TagsNo tags attached.

Activities

ovenwerks

2016-11-07 19:32

reporter   ~0018921

I am not sure what the expected response is as compared to the actual response. A hidden track is a hidden track, where the hidden bit is set is not relevant. It shows as hidden in the editor, mixer and any control surface.

jams

2016-11-08 06:12

reporter   ~0018925

In version 2, 3 and 4 it was possible for the editor window to hide or not the tracks without affecting the mixer window and we must admit that it was very convenient in the sense that we have not necessarily need to display the same between the editor mode and mixer mode.

in french:

Dans la version 2, 3 et 4 il était possible depuis la fenêtre de l'éditeur de cacher ou non les pistes sans que cela affecte la fenêtre du mixeur et il faut bien avouer que c'était très pratique dans le sens ou nous n'avons pas forcément besoin d'afficher la même chose entre le mode éditeur et le mode mixeur.

ovenwerks

2016-11-08 06:42

reporter   ~0018926

Yes, but it was broken. It worked that way some of the time and not others. Hide a track in a group and both editor and mixer were hidden, hide a track outside of a group and it only affected that part of the GUI... well sort of. Hide a track in the editor and it was hidden on a control surface... hide another track in the mixer and the control surface switched to show what the mixer showed. So it only worked as you described part of the time and even then it caused control surfaces trouble all the time. It was fixed by moving the hidden bit to the route instead of the GUI. The GUI tells the route to hide, the route tells the mixer, editor and any control surfaces it is hidden. (actually it signals it's status has changed)

So yes this is a change from the way it used to be, but the old way was broken for some important uses such as control surfaces and groups.

jams

2016-11-08 19:11

reporter   ~0018928

Ok I understand now, thank you for time on the issue.

in french:


Ok je comprend maintenant, merci d'avoir pris le temps de plancher sur la question

system

2020-04-19 20:18

developer   ~0023637

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-08-12 12:53 jams New Issue
2016-11-07 19:32 ovenwerks Note Added: 0018921
2016-11-07 19:32 ovenwerks Status new => feedback
2016-11-08 06:12 jams Note Added: 0018925
2016-11-08 06:12 jams Status feedback => new
2016-11-08 06:42 ovenwerks Note Added: 0018926
2016-11-08 19:11 jams Note Added: 0018928
2016-11-08 19:49 ovenwerks Status new => resolved
2016-11-08 19:49 ovenwerks Resolution open => no change required
2016-11-08 19:49 ovenwerks Assigned To => ovenwerks
2020-04-19 20:18 system Note Added: 0023637
2020-04-19 20:18 system Status resolved => closed